Bug 1260365 - Guest image created coredump after installation.
Guest image created coredump after installation.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Max Reitz
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 05:22 EDT by xiagao
Modified: 2015-12-04 11:56 EST (History)
8 users (show)

See Also:
Fixed In Version: qemu-kvm-rhev-2.3.0-26.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 11:56:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file report (5.09 KB, text/plain)
2015-09-06 05:22 EDT, xiagao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 16:11:56 EST

  None (edit)
Description xiagao 2015-09-06 05:22:30 EDT
Created attachment 1070669 [details]
core file report

Description of problem:
Core was generated by `/bin/qemu-img check $guest-img` when finished RHEL6.7 guest installation

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-21.el7.x86_64
qemu-img-rhev-2.3.0-21.el7.x86_64
kernel-3.10.0-310.el7.x86_64

How reproducible:
1/5

Steps to Reproduce:
1.Create image by command: 
/bin/qemu-img create -f qcow2 /home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64-virtio.qcow2 20G

2.Install rhel6.7 guest in the image
/usr/libexec/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga cirrus  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-virt-tests-vm1-qmpmonitor1-20150906-133429-W9ukBPrL,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-virt-tests-vm1-catch_monitor-20150906-133429-W9ukBPrL,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idYZPgzF  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20150906-133429-W9ukBPrL,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20150906-133429-W9ukBPrL,path=/tmp/seabios-20150906-133429-W9ukBPrL,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20150906-133429-W9ukBPrL,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=threads,format=qcow2,file=/home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=1,bus=pci.0,addr=04,disable-legacy=off,disable-modern=on \
    -device virtio-net-pci,mac=9a:38:39:3a:3b:3c,id=idX3RTca,vectors=4,netdev=idTCvOll,bus=pci.0,addr=05,disable-legacy=off,disable-modern=on  \
    -netdev tap,id=idTCvOll,vhost=on,vhostfd=24,fd=23  \
    -m 16384  \
    -smp 32,maxcpus=32,cores=16,threads=1,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt \
    -drive id=drive_cd1,if=none,snapshot=off,aio=threads,media=cdrom,file=/home/my_auto/autotest-devel/client/tests/virt/shared/data/isos/linux/RHEL6.7-Server-x86_64.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bootindex=2,bus=ide.0,unit=0 \
    -drive id=drive_unattended,if=none,snapshot=off,aio=threads,media=cdrom,file=/home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64/ks.iso \
    -device ide-cd,id=unattended,drive=drive_unattended,bootindex=3,bus=ide.0,unit=1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -kernel '/home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64/vmlinuz'  \
    -append 'ks=cdrom nicdelay=60  console=ttyS0,115200 console=tty0'  \
    -initrd '/home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64/initrd.img'  \
    -vnc :2  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off,strict=off  \
    -no-shutdown \
    -enable-kvm

3.After installation,check the image
Running '/bin/qemu-img check /home/my_auto/autotest-devel/client/tests/virt/shared/data/images/rhel67-64-virtio.qcow2'

Actual results:
Core was generated by `/bin/qemu-img check $guest-img`

Expected results:
no core created.

Additional info:
1.core file report
see attachment.

2.cpu info
processor	: 39
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E7-4830 v2 @ 2.20GHz
stepping	: 7
microcode	: 0x70d
cpu MHz		: 2200.000
cache size	: 20480 KB
physical id	: 1
siblings	: 20
core id		: 12
cpu cores	: 10
apicid		: 57
initial apicid	: 57
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
Comment 2 Ademar Reis 2015-09-08 16:45:45 EDT
Fix is simple, being sent upstream. Since this is a crash, I'm requesting exception flag.
Comment 4 Miroslav Rezanina 2015-09-24 02:45:13 EDT
Fix included in qemu-kvm-rhev-2.3.0-26.el7
Comment 5 xiagao 2015-09-28 09:16:59 EDT
verification version:

3.10.0-319.el7.x86_64
qemu-kvm-rhev-2.3.0-26.el7.x86_64

Can't reproduce this issue for 10 times. So i think it's verified.
Comment 6 juzhang 2015-09-28 21:05:46 EDT
According to comment5, set this issue as verified.
Comment 8 errata-xmlrpc 2015-12-04 11:56:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html

Note You need to log in before you can comment on or make changes to this bug.