Bug 1260428 - [vdsm] Cannot upgrade storage pool when there was/is an unavailable domain
[vdsm] Cannot upgrade storage pool when there was/is an unavailable domain
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
All Linux
high Severity high (vote)
: ovirt-4.0.2
: 4.18.9
Assigned To: Liron Aravot
Kevin Alon Goldblatt
:
Depends On:
Blocks: 1260429
  Show dependency treegraph
 
Reported: 2015-09-06 14:53 EDT by Liron Aravot
Modified: 2016-08-12 10:23 EDT (History)
27 users (show)

See Also:
Fixed In Version: v4.18.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242092
Environment:
Last Closed: 2016-08-12 10:23:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ykaul: ovirt‑4.0.z+
rule-engine: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45774 master ABANDONED sp: allow executing upgradePool even if there is a pending update 2016-03-19 21:55 EDT
oVirt gerrit 57188 master MERGED sp: allow executing upgradePool even if there is a pending update 2016-07-11 10:44 EDT
oVirt gerrit 59514 master MERGED sp: try lock when executing user initated pool upgrade 2016-07-11 10:44 EDT
oVirt gerrit 60519 ovirt-4.0 MERGED sp: allow executing upgradePool even if there is a pending update 2016-07-17 07:42 EDT
oVirt gerrit 60520 ovirt-4.0 MERGED sp: try lock when executing user initated pool upgrade 2016-07-17 07:43 EDT

  None (edit)
Comment 1 Liron Aravot 2015-09-10 03:45:13 EDT
VDSM maintainers don't want to incorporate that fix for 3.5.5 as there is a workaround, after https://bugzilla.redhat.com/show_bug.cgi?id=1260429 is solved the user can deactivate the problematic domain and then proceed with the upgrade.

postponing to 3.6
Comment 2 Allon Mureinik 2016-03-27 10:52:57 EDT
Liron - the attached patch is abandoned. Is this something we'd EVER want to solve? The workaround seems sufficient to me - if there's really a problem accessing the domain, you can't use it, and should probably remove it from the pool.
Comment 3 Liron Aravot 2016-03-28 05:33:55 EDT
Allon, imo it is.
When we have a problematic domain it may become available later, so we won't always want to force the user to remove it and then add it again in order to perform an upgrade - the upgrade should be allowed regardless, when the domain will become available it'll be upgraded to the needed version (as happens today).
Comment 4 Mike McCune 2016-03-28 18:54:17 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Sandro Bonazzola 2016-05-02 06:00:55 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 6 Yaniv Lavi 2016-05-23 09:16:56 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 7 Yaniv Lavi 2016-05-23 09:20:47 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 8 Allon Mureinik 2016-07-08 05:30:31 EDT
Any news?
Comment 9 Allon Mureinik 2016-07-17 11:01:56 EDT
Upgrade is always a hot topic. Liron - can you please supply some doctext for this BZ? Thanks!
Comment 10 Yaniv Lavi 2016-07-21 08:18:25 EDT
Should this be ON_QA?
Comment 11 Kevin Alon Goldblatt 2016-07-25 12:25:12 EDT
Tested with the following code:
-------------------------------------
rhevm-4.0.2-0.1.rc.el7ev.noarch
vdsm-4.18.8-1.el7ev.x86_64

Verified with the following scenario:
-------------------------------------
Steps to Reproduce:
1. Create new v3.0 DC, Cluster, Add new host
2. Add new storage domain to DC
3. Move host to maintenance
4. block connection between the host and the non master domain
5. activate the host, wait for it to become the spm
6. try to upgrade the DC -> The upgrade is successfull


Actual results:
The DC upgrade is successfull


Moving to VERIFIED!

Note You need to log in before you can comment on or make changes to this bug.