Bug 1260432 - Python libs should be in a separate sub-package
Python libs should be in a separate sub-package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All All
unspecified Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 189399 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 15:49 EDT by Florent Le Coz
Modified: 2015-09-17 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 12:06:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to apply on avahi.spec (1.51 KB, patch)
2015-09-06 15:49 EDT, Florent Le Coz
no flags Details | Diff

  None (edit)
Description Florent Le Coz 2015-09-06 15:49:30 EDT
Created attachment 1070779 [details]
Patch to apply on avahi.spec

At the moment, the python files are installed by the avahi-ui-tools package, which is quite huge and has some heavy dependencies (tigervnc to name most “invasive” one).

However, some programs only need the few python files, not the whole avahi-ui-tools (the gajim package for example depends on avahi-ui-tools, which makes it install tigervnc, which is completely unrelated and unnecessary for gajim to work).

So, attached is a patch for avahi.spec that separates the python files into a subpackage named python-avahi. After this change, other packages like gajim could replace their dependency to only need python-avahi (and not avahi-ui-tools).

(I made the avahi-ui-tools subpackage depend on python-avahi, this way existing packages that depend on avahi-ui-tools just to get the python will not be broken.)

Feel free to use the given patch, or to make this change in some other way.

Thanks.
Comment 1 Rex Dieter 2015-09-17 12:06:02 EDT
* Sun Jun 21 2015 Bastien Nocera <bnocera@redhat.com> 0.6.31-36
- Split off Python bindings, add Python3 support
Comment 2 Florent Le Coz 2015-09-17 13:08:49 EDT
*** Bug 189399 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.