Bug 1260435 - remove brick from replica with arbiter
remove brick from replica with arbiter
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.2
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-06 16:40 EDT by Pavel Pulec
Modified: 2015-12-07 08:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 08:42:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Pulec 2015-09-06 16:40:12 EDT
Description of problem:

I tried to remove 3 bricks from "2 x 3" (with arbiter) and no data was rebalanced.


Version-Release number of selected component (if applicable):

glusterfs 3.7.2 built on Jun 23 2015 12:13:13

How reproducible:

Create replica 2 x 3 with arbiter and then remove 3 bricks


Steps to Reproduce:
1. gluster volume create replica_name replica 3 arbiter 1 host:/mnt/brick/1 host:/mnt/brick/2 host:/mnt/brick/3 host:/mnt/brick/4 host:/mnt/brick/5 host:/mnt/brick/6 force
2. add some data
3. gluster volume remove-brick replica_name host:/mnt/brick/4 host:/mnt/brick/5 host:/mnt/brick/6 start
4. gluster volume remove-brick replica5 host:/mnt/brick/4 host:/mnt/brick/5 host:/mnt/brick/6 status

Actual results:

- rebalancing of all files failed

Node Rebalanced-files          size       scanned      failures       skipped               status   run time in secs
---------      -----------   -----------   -----------   -----------   -----------         ------------     --------------
localhost                0        0Bytes            10             5             0            completed               0.00

Expected results:

All files should be re-balanced and I should be able to remove the bricks from the volume.


Additional info:

kernel: 2.6.32-504.23.4.el6.x86_64
Comment 1 Ravishankar N 2015-11-29 23:37:54 EST
Hi Pavel. I'm not able to recreate this issue on 3.7.2 or the latest 3.7.6. Are you still able to see this issue? What do the rebalance logs say for the files that are marked as failure?
Comment 2 Pavel Pulec 2015-12-07 08:42:14 EST
Hi Ravishankar,
I tried to replicate that issue on the latest version 3.7.6 and a rebalance with arbiter works correctly. I'm closing this issue as it's probably fixed in the newer version or I was doing something wrong.

Note You need to log in before you can comment on or make changes to this bug.