Bug 1260480 - [RFE] For 'New' host function, change 'Address' to 'Hostname'
[RFE] For 'New' host function, change 'Address' to 'Hostname'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.3
All Linux
medium Severity low
: ovirt-4.2.0
: 4.2.0
Assigned To: nobody nobody
David Necpal
: EasyFix, FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 00:54 EDT by Marcus West
Modified: 2018-05-15 13:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-15 13:36:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dnecpal: testing_plan_complete-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78945 master MERGED webadmin: address of host renamed to hostname 2017-07-18 14:29 EDT
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 13:38 EDT

  None (edit)
Description Marcus West 2015-09-07 00:54:18 EDT
Description of problem:

For 'New' host function, change 'address' to 'Hostname/IP'

Version-Release number of selected component (if applicable):

RHEV 3.5

How reproducible:

always

Additional info:

The customer feels that it would be a bit more intuitive if the 'Address' field was renamed to 'Hostname/IP', as this a description, that they are more familiar with, and consistent with other products they use.
Comment 1 Oved Ourfali 2015-09-07 08:02:58 EDT
The DNS name may be different than the hostname.
Right terminology would be FQDN/IP.
I think address is clear.

Moran - thoughts?
Comment 2 Moran Goldboim 2015-09-17 04:35:39 EDT
(In reply to Oved Ourfali from comment #1)
> The DNS name may be different than the hostname.
> Right terminology would be FQDN/IP.
> I think address is clear.
> 
> Moran - thoughts?

Oved, can we add this description in a tool tip, something that would make it clearer and use IP address, FQDN terminology?
Comment 3 Oved Ourfali 2015-09-17 05:12:59 EDT
(In reply to Moran Goldboim from comment #2)
> (In reply to Oved Ourfali from comment #1)
> > The DNS name may be different than the hostname.
> > Right terminology would be FQDN/IP.
> > I think address is clear.
> > 
> > Moran - thoughts?
> 
> Oved, can we add this description in a tool tip, something that would make
> it clearer and use IP address, FQDN terminology?

Tool tip on what? on the text itself? the text box?
Comment 4 Moran Goldboim 2015-10-19 02:38:12 EDT
(In reply to Oved Ourfali from comment #3)
> (In reply to Moran Goldboim from comment #2)
> > (In reply to Oved Ourfali from comment #1)
> > > The DNS name may be different than the hostname.
> > > Right terminology would be FQDN/IP.
> > > I think address is clear.
> > > 
> > > Moran - thoughts?
> > 
> > Oved, can we add this description in a tool tip, something that would make
> > it clearer and use IP address, FQDN terminology?
> 
> Tool tip on what? on the text itself? the text box?

usually done on a "?" icon next to textbox, but let's sync toward RHEV 4 depending on UX guidelines for this version.
Comment 5 Yaniv Kaul 2016-03-03 09:27:32 EST
(In reply to Moran Goldboim from comment #4)
> (In reply to Oved Ourfali from comment #3)
> > (In reply to Moran Goldboim from comment #2)
> > > (In reply to Oved Ourfali from comment #1)
> > > > The DNS name may be different than the hostname.
> > > > Right terminology would be FQDN/IP.
> > > > I think address is clear.
> > > > 
> > > > Moran - thoughts?
> > > 
> > > Oved, can we add this description in a tool tip, something that would make
> > > it clearer and use IP address, FQDN terminology?
> > 
> > Tool tip on what? on the text itself? the text box?
> 
> usually done on a "?" icon next to textbox, but let's sync toward RHEV 4
> depending on UX guidelines for this version.

Now's the time to sync - please change the head if it's going to be a tooltip.
Comment 6 Moran Goldboim 2016-03-07 04:45:34 EST
(In reply to Yaniv Kaul from comment #5)
> (In reply to Moran Goldboim from comment #4)
> > (In reply to Oved Ourfali from comment #3)
> > > (In reply to Moran Goldboim from comment #2)
> > > > (In reply to Oved Ourfali from comment #1)
> > > > > The DNS name may be different than the hostname.
> > > > > Right terminology would be FQDN/IP.
> > > > > I think address is clear.
> > > > > 
> > > > > Moran - thoughts?
> > > > 
> > > > Oved, can we add this description in a tool tip, something that would make
> > > > it clearer and use IP address, FQDN terminology?
> > > 
> > > Tool tip on what? on the text itself? the text box?
> > 
> > usually done on a "?" icon next to textbox, but let's sync toward RHEV 4
> > depending on UX guidelines for this version.
> 
> Now's the time to sync - please change the head if it's going to be a
> tooltip.

since we aren't touching vm area in 4.0 but probably just in 4.1. i'm postponing that one to 4.1 timeframe.
Comment 7 Yaniv Kaul 2017-03-13 03:58:55 EDT
OK, it missed 4.1 as well. Moran?
Comment 8 Martin Perina 2017-05-17 05:26:29 EDT
So how about to use 'Hostname' instead of 'Address' and add question mark icon after 'Hostname' text with tool tip "Please enter fully qualified domain name or IP address of the host"?
This is the same approach which we are for example using inside 'Console' or 'Kernel' tabs within 'New Host' dialog
Comment 9 Moran Goldboim 2017-05-29 08:43:31 EDT
(In reply to Martin Perina from comment #8)
> So how about to use 'Hostname' instead of 'Address' and add question mark
> icon after 'Hostname' text with tool tip "Please enter fully qualified
> domain name or IP address of the host"?
> This is the same approach which we are for example using inside 'Console' or
> 'Kernel' tabs within 'New Host' dialog

Sounds good to me.
Comment 11 Yaniv Lavi 2017-07-04 03:01:46 EDT
We don't support IP address for hosts, since some features will not work and this can be fragile. Please consider only mentioning host name.
Comment 12 Oved Ourfali 2017-07-04 03:03:47 EDT
(In reply to Yaniv Lavi from comment #11)
> We don't support IP address for hosts, since some features will not work and
> this can be fragile. Please consider only mentioning host name.

That's a question for Moran.
Comment 13 Moran Goldboim 2017-07-04 03:37:07 EDT
(In reply to Oved Ourfali from comment #12)
> (In reply to Yaniv Lavi from comment #11)
> > We don't support IP address for hosts, since some features will not work and
> > this can be fragile. Please consider only mentioning host name.
> 
> That's a question for Moran.

Yaniv, can you please specify the features that wouldn't work with IP address only. if we get to the conclusion it's harms basic functionality or the effect is to wide, i agree we should consider to remove IP address support. but that would probably effect upgrade flows and current deployments.

in general i think we would still want to support both options for the simplicity of the deployment process and existing users deployments. nevertheless, i think it's a good info to add to the help icon suggested at comment 8. we can probably have this addition- "warning- not configuring the host with a resolvable FQDN can prevent usage of several functions in the product. for more details please refer to documentation"
Comment 17 Yaniv Lavi 2017-07-06 09:06:37 EDT
(In reply to Moran Goldboim from comment #13)
> (In reply to Oved Ourfali from comment #12)
> > (In reply to Yaniv Lavi from comment #11)
> > > We don't support IP address for hosts, since some features will not work and
> > > this can be fragile. Please consider only mentioning host name.
> > 
> > That's a question for Moran.
> 
> Yaniv, can you please specify the features that wouldn't work with IP
> address only. if we get to the conclusion it's harms basic functionality or
> the effect is to wide, i agree we should consider to remove IP address
> support. but that would probably effect upgrade flows and current
> deployments.
> 
 
I don't have a list, but the OVN/Neutron integration will probably not work.
Comment 19 David Necpal 2017-08-18 10:39:03 EDT
Verified on version 4.2.0-0.0.master.20170816180818.gitfa401fb.el7.centos
Comment 23 errata-xmlrpc 2018-05-15 13:36:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Note You need to log in before you can comment on or make changes to this bug.