Bug 1260487 - sometimes after logout from gnome session, cannot re-login
sometimes after logout from gnome session, cannot re-login
Status: CLOSED DUPLICATE of bug 1263208
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 01:17 EDT by Joachim Backes
Modified: 2016-01-04 06:20 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 06:20:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl --user (at 06:59), grepping for gdm (45.73 KB, text/plain)
2015-09-07 01:17 EDT, Joachim Backes
no flags Details
~/.local/share/xorg/Xorg.0.log (60.21 KB, text/plain)
2015-09-07 01:20 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2015-09-07 01:17:24 EDT
Created attachment 1070830 [details]
journalctl --user (at 06:59), grepping for gdm

Description of problem:

I'm running gnome3 desktop, and gdm as desktop manager. It happens rather often that after logging out and trying to relogin and after having entered the correct password at the gdm prompt, the login is rejected, so as if trying a wrong password.

Inspecting the syslog with "journalctl --user" shows an error message:



Version-Release number of selected component (if applicable):
gdm-3.17.90-1.fc23.x86_64

How reproducible:
Not always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:See attachments
Comment 1 Joachim Backes 2015-09-07 01:20:23 EDT
Created attachment 1070831 [details]
~/.local/share/xorg/Xorg.0.log
Comment 2 Joachim Backes 2015-09-12 01:44:18 EDT
1. Sometimes, it helps to try the login again (2-3 times), until the login is accepted

2. Usually (but not alwyas!), it helps to kill gdm and wait until the login-screen reappears.
Comment 3 Joachim Backes 2015-09-24 05:58:07 EDT
Still same effect after applying the gnome mega update including gdm-3.18.0-1.fc23.x86_64!
Comment 4 Joachim Backes 2015-09-25 02:58:10 EDT
Tail of /var/log/messages:

Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: Fatal server error:
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE) xf86OpenConsole: Cannot open virtual console 3 (Permission denied)
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE)
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE)
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: Please consult the Fedora Project support
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: at http://wiki.x.org
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: for help.
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE) Please also check the log file at "/home/backes/.local/share/xorg/Xorg.0.log" for additional information.
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE)
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: (EE) Server terminated with error (1). Closing log file.
Sep 25 08:54:17 eule /usr/libexec/gdm-x-session: Unable to run X server
Comment 5 joerg.lechner 2015-09-28 14:41:43 EDT
For me it seems, that there is a timer (about 10 -15 sec?)
running and blocking the re-login. When I tested this,
immediately after logoff user, I can not login.
Trying 2 to 3 times, about the 3rd time
I can login again. If I wait about
20sec after logoff user, I can login immediately.
Comment 6 Damien Gombault 2015-12-23 17:42:06 EST
Duplicate of bug 1263208 ?
Comment 7 Joachim Backes 2016-01-01 04:07:11 EST
The issue seemed to be solved for some months, but now, seeing this effect again. For details see:

https://lists.fedoraproject.org/pipermail/users/2016-January/467687.html
Comment 8 Sebastian 2016-01-03 15:04:55 EST
I have exactly the same problem. I am running fedora 23 on a Thinkpad L530.
Comment 9 Andre Robatino 2016-01-04 04:16:09 EST
Maybe a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1263208 ? (I haven't tested this myself, but remember seeing that bug.)
Comment 10 Kamil Páral 2016-01-04 06:20:41 EST
Yes, it's a dupe.

*** This bug has been marked as a duplicate of bug 1263208 ***

Note You need to log in before you can comment on or make changes to this bug.