Bug 126049 - USB modem: cdc_acm driver not loaded, modprobe.conf not configured
USB modem: cdc_acm driver not loaded, modprobe.conf not configured
Status: CLOSED DUPLICATE of bug 100503
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 11:29 EDT by John Reiser
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/hwconf (6.56 KB, text/plain)
2004-06-15 11:30 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2004-06-15 11:29:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
USB modem is detected and configured at boot in /etc/sysconfig/hwconf,
but kernel module cdc_acm is not loaded, nor is the module listed in
/etc/modprobe.conf.  This causes all downstream uses to fail because
/dev/input/ttyACM0 cannot be opened.


Version-Release number of selected component (if applicable):
kudzu-1.1.62-1

How reproducible:
Always

Steps to Reproduce:
1. During GRUB boot screen, plug in and turn on USB modem.
2. Boot.

    

Actual Results:  kudzu detects and configures modem in
/etc/sysconfig/hwconf, but lists no driver.  kudzu forgets to load
kernel module cdc_acm, so attempts to use modem during current boot
will fail until kernel module cdc_acm is loaded manually.  kudzu
forgets to put cdc_acm in /etc/modprobe.conf, so future boots [during
which kudzu is quiet because /etc/sysconfig/hwconf is already OK] also
fail because cdc_acm is not loaded.

Expected Results:  kudzu detects and configures modem in
/etc/sysconfig/hwconf, and lists cdc_acm as driver.  kudzu causes
kernel module cdc_acm to be loaded.  kudzu lists cdc_acm in
/etc/modprobe.conf so that modem works OK in future boots.

Additional info:

Similar problem has existed in RedHat distributions for two years. 
See bug 100503 and bug 98790.

Contents of /etc/sysconfig/hwconf will be attached.
Comment 1 John Reiser 2004-06-15 11:30:27 EDT
Created attachment 101151 [details]
/etc/sysconfig/hwconf
Comment 2 Bill Nottingham 2004-06-29 00:21:19 EDT

*** This bug has been marked as a duplicate of 100503 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.