Bug 1260493 - Errata dialog is not loaded with the selected filters
Errata dialog is not loaded with the selected filters
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alexander Wels
movciari
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 02:07 EDT by Moti Asayag
Modified: 2016-02-10 14:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:20:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
ylavi: planning_ack?
oourfali: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47749 master MERGED webadmin: Errata dialog filter Never
oVirt gerrit 47765 ovirt-engine-3.6 MERGED webadmin: Errata dialog filter Never

  None (edit)
Description Moti Asayag 2015-09-07 02:07:58 EDT
Description of problem:
In Host/VM Errata's sub-tab a count of Errata by type is shown.
When the user clicks on a specific type, a dialog is opened to show all of the errata of the same type.

However, during the fetch of the Errata, all the filter's checkboxes (all types) are selected, and only after the Errata are retrieved, the filters are updated accordingly to the user original selection/type.

Version-Release number of selected component (if applicable):
commit 6b86f301d5eaba7ffa10b829bbcdc8d1acac3740

How reproducible:
always

Steps to Reproduce:
1. Select VM/Host with Errata
2. Click on Errata sub-tab
3. Select a specific type

Actual results:
Until the Errata is shown, all of the checkboxes are selected

Expected results:
Only the checkbox according to the user selection should be checked (and remain checked after the Errata is retrieved)

Additional info:
Comment 1 Greg Sheremeta 2015-09-08 15:33:19 EDT
We should simply hide the filter panel while the loading indicator is up.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 07:01:32 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Yaniv Lavi 2015-10-29 08:32:21 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Sandro Bonazzola 2015-12-16 07:20:33 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.