This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260548 - Upgrade rhev-h from 7.1 to 7.2 via CMD failed
Upgrade rhev-h from 7.1 to 7.2 via CMD failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity urgent
: ovirt-3.6.1
: 3.6.0
Assigned To: Ryan Barry
cshao
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 04:38 EDT by cshao
Modified: 2016-03-09 09:36 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:36:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/*.* + sosreport (5.58 MB, application/x-gzip)
2015-09-07 04:38 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46043 master MERGED Move initramfs regeneration until after grub is installed Never
oVirt gerrit 46105 ovirt-3.6 MERGED Move initramfs regeneration until after grub is installed Never

  None (edit)
Description cshao 2015-09-07 04:38:01 EDT
Created attachment 1070861 [details]
/var/log/*.*   +  sosreport

Description of problem:
Upgrade rhev-h from 7.1 to 7.2 via CMD failed.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.1-20150827.1
rhev-hypervisor-7-7.2-20150831.0
ovirt-node-3.3.0-0.2.20150722git7eba125.el7ev.noarch
vdsm-4.17.3-1.el7ev.noarch
RHEV-M vt16.9
Red Hat Enterprise Virtualization Manager Version: 3.5.4-1.3.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh 7.1 3.5.4GA build(rhev-hypervisor-7-7.1-20150827.1).
2. Upgrade RHEV-H 7.1 to 7.2 via CMD, append "upgrade" to kernel command line.
3. Reboot host, focus on grub.
4. login the host.


Actual results:
1. After step 3, there is only rhev-h 7.1 in grub. no 7.2.
2. Continue boot from 7.1 can successful.


# cat /dev/.initramfs/live/grub2/grub.cfg 

#default saved
set timeout=5
#hiddenmenu
menuentry "RHEV-H 7.1-20150827.1.el7ev" {
set root=(hd0,3)
search --no-floppy --label Root --set root
linux /vmlinuz0 root=live:LABEL=Root ro rootfstype=auto rootflags=ro ksdevice=bootif rd.dm=0  rd.md=0 crashkernel=256M lang= max_loop=256 rhgb quiet elevator=deadline rd.live.check rd.luks=0 rd.live.image nomodeset
initrd /initrd0.img

Expected results:
Upgrade rhev-h from 7.1 to 7.2 via CMD can successful.

Additional info:
Comment 2 Fabian Deutsch 2015-10-19 09:41:38 EDT
If it's about initramfs regeneration then it should not affect 3.5.z, as the regeneration is just in 3.6.0.
Comment 3 cshao 2015-11-11 04:08:11 EST
Test version:
rhev-hypervisor7-7.2-20151104.0
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch 

Test steps:
1. Install rhevh 7.1 3.5.4GA build(rhev-hypervisor-7-7.1-20150827.1).
2. Upgrade RHEV-H 7.1 to 7.2 latest via CMD, append "upgrade" to kernel command line.
3. Reboot host, focus on grub.
4. login the host.

Test result:
Upgrade rhev-h from 7.1 to 7.2 latest via CMD can successful.

So the bug is fixed, change bug status to VERIFIED.
Comment 5 errata-xmlrpc 2016-03-09 09:36:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.