Bug 1260555 - grub2 shell function version_find_latest() failed to identify latest RHEL kernel
grub2 shell function version_find_latest() failed to identify latest RHEL kernel
Status: CLOSED DUPLICATE of bug 1124074
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: rmarshall
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 04:55 EDT by Till Maas
Modified: 2015-10-12 14:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 14:34:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2015-09-07 04:55:51 EDT
Description of problem:
grub2 uses a shell function called version_find_latest() to find the latest RHEL kernel. However sometimes it fails to identify the latest kernel resulting in an older kernel be booted instead of the latest one.

Version-Release number of selected component (if applicable):
grub2-tools-2.02-0.16.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1. source /usr/share/grub/grub-mkconfig_lib  # get shell functions
2. version_find_latest /boot/vmlinuz-3.10.0-229.el7.x86_64 /boot/vmlinuz-3.10.0-229.11.1.el7.x86_64


Actual results:
/boot/vmlinuz-3.10.0-229.el7.x86_64

Expected results:
It should output the latest release, which is:
/boot/vmlinuz-3.10.0-229.11.1.el7.x86_64

Additional info:
Comment 2 Akemi Yagi 2015-09-14 08:26:15 EDT
I believe this is being addressed in BZ #1124074 and the fix is coming soon.
Comment 3 rmarshall 2015-10-12 14:34:44 EDT

*** This bug has been marked as a duplicate of bug 1124074 ***

Note You need to log in before you can comment on or make changes to this bug.