Bug 1260558 - Unexpected output from gdb on ppc64le
Unexpected output from gdb on ppc64le
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdb (Show other bugs)
7.2
ppc64le Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Kratochvil
Miroslav Franc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 05:00 EDT by Robert Kuska
Modified: 2016-04-18 06:17 EDT (History)
10 users (show)

See Also:
Fixed In Version: gdb-7.6.1-79.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:03:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Kuska 2015-09-07 05:00:18 EDT
Tests within test_gdb in python fails on ppc64le architecture because gdb produces unexpected output.

Examples of failures:
FAIL: test_NULL_ob_type (test.test_gdb.PrettyPrintTests)
Ensure that a PyObject* with NULL ob_type is handled gracefully
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 487, in test_NULL_ob_type
    'set op->ob_type=0')
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 454, in assertSane
    cmds_after_breakpoint=cmds_after_breakpoint)
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 234, in get_gdb_repr
    import_site=import_site)
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 219, in get_stack_trace
    self.assertEqual(unexpected_errlines, [])
AssertionError: Lists differ: ['[10927 refs]', 'No symbol "o... != []
First list contains 3 additional elements.
First extra element 0:
[10927 refs]
- ['[10927 refs]', 'No symbol "op" in current context.', 'No stack.']
+ []
======================================================================
FAIL: test_NULL_ptr (test.test_gdb.PrettyPrintTests)
Ensure that a NULL PyObject* is handled gracefully
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 479, in test_NULL_ptr
    'backtrace'])
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 234, in get_gdb_repr
    import_site=import_site)
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 219, in get_stack_trace
    self.assertEqual(unexpected_errlines, [])
AssertionError: Lists differ: ['[10927 refs]', 'No symbol "o... != []
First list contains 3 additional elements.
First extra element 0:
[10927 refs]
- ['[10927 refs]', 'No symbol "op" in current context.', 'No stack.']
+ []
======================================================================
FAIL: test_builtin_function (test.test_gdb.PrettyPrintTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 618, in test_builtin_function
    gdb_repr, gdb_output = self.get_gdb_repr('print len')
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 234, in get_gdb_repr
    import_site=import_site)
  File "/builddir/build/BUILD/Python-2.7.5/Lib/test/test_gdb.py", line 219, in get_stack_trace
    self.assertEqual(unexpected_errlines, [])
AssertionError: Lists differ: ['[10927 refs]', 'No stack.'] != []
First list contains 2 additional elements.
First extra element 0:
[10927 refs]
- ['[10927 refs]', 'No stack.']
+ []
======================================================================


Affected component:
gdb-7.6.1-78.el7
Comment 3 Jan Kratochvil 2015-09-07 18:03:29 EDT
[ppc64le] Use skip_entrypoint for skip_trampoline_code
https://sourceware.org/ml/gdb-patches/2015-09/msg00080.html
[ppc64le patch v2] Use skip_entrypoint for skip_trampoline_code
https://sourceware.org/ml/gdb-patches/2015-09/msg00081.html

RHEL-7.2 scratch build (running):
  https://brewweb.devel.redhat.com/taskinfo?taskID=9807307
Comment 8 errata-xmlrpc 2015-11-19 08:03:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2089.html

Note You need to log in before you can comment on or make changes to this bug.