Bug 1260561 - transport and port should be optional arguments for glfs_set_volfile_server
transport and port should be optional arguments for glfs_set_volfile_server
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
Sudhir D
:
Depends On:
Blocks: 1247933
  Show dependency treegraph
 
Reported: 2015-09-07 05:18 EDT by Raghavendra Talur
Modified: 2016-06-16 09:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test to reproduce the issue (1.93 KB, text/x-csrc)
2015-09-07 05:22 EDT, Raghavendra Talur
no flags Details

  None (edit)
Description Raghavendra Talur 2015-09-07 05:18:23 EDT
Description of problem:

Only server is the required argument for glfs_set_volfile_server
    and both transport and port are optional. When glfs_set_volfile_server
    is invocated multiple times, only on the first invocation we replace
    port 0 with 24007 and transport NULL with "localhost".
    
    Hence, replacing the parameters at the entry function is the right way.


How reproducible:
Always


Steps to Reproduce:
1. Download the attached program.
2. Find the readme within the file.
3. Follow the instructions.
Comment 1 Vijay Bellur 2015-09-07 05:19:53 EDT
REVIEW: http://review.gluster.org/12114 (gfapi: transport and port are optional for glfs_set_volfile_server) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Raghavendra Talur 2015-09-07 05:22:32 EDT
Created attachment 1070875 [details]
test to reproduce the issue
Comment 3 Vijay Bellur 2015-09-08 08:50:10 EDT
REVIEW: http://review.gluster.org/12114 (gfapi: transport and port are optional for glfs_set_volfile_server) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 4 Niels de Vos 2016-06-16 09:35:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.