Bug 1260608 - Error creating a storage domain
Error creating a storage domain
Status: CLOSED DUPLICATE of bug 1259310
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.6.0
Assigned To: Greg Padgett
Aharon Canan
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 07:13 EDT by Karolína Hajná
Modified: 2015-09-08 10:24 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 08:47:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm-log (96.65 KB, application/x-gzip)
2015-09-08 08:18 EDT, Petr Kubica
no flags Details
engine-logs (1.48 MB, application/x-gzip)
2015-09-08 08:18 EDT, Petr Kubica
no flags Details

  None (edit)
Description Karolína Hajná 2015-09-07 07:13:37 EDT
Description of problem:
While creating new storage domain, there is an error:

"Error while executing action New NFS Storage Domain: Error creating a storage domain"

Version-Release number of selected component (if applicable):
3.6.0-0.13.master.el6

How reproducible:
100%

Steps to Reproduce:
1. Create new storage domain

Actual results:
error

Expected results:
storage domain created

Additional info:
engine log attached
Comment 1 Pavel Stehlik 2015-09-08 03:58:07 EDT
The reason is obvious - there is nothing to investigate. If we'll have more info we'll reopen.
Comment 2 Petr Kubica 2015-09-08 08:11:44 EDT
Hi, I have the same issue. 
If you make a clean installation od 3.6.0-11, you cannot add a storage domain. 

I have installed vdsm-4.17.5-1, with previous version of vdsm (4.17.3) it works

I found in vdsm log:
Thread-1320::ERROR::2015-09-08 13:44:35,616::hsm::2454::Storage.HSM::(connectStorageServer) Could not connect to storageServer
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/hsm.py", line 2451, in connectStorageServer
    conObj.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 419, in connect
    return self._mountCon.connect()
  File "/usr/share/vdsm/storage/storageServer.py", line 236, in connect
    self.getMountObj().getRecord().fs_file)
  File "/usr/share/vdsm/storage/fileSD.py", line 76, in validateDirAccess
    (os.R_OK | os.X_OK))
  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in validateAccess
  File "/usr/lib64/python2.7/multiprocessing/managers.py", line 759, in _callmethod
    kind, result = conn.recv()
AttributeError: 'module' object has no attribute 'Timeout'

engine.log:

2015-09-08 13:44:35,845 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] Lock Acquired to object 'EngineLock:{exclusiveLocks='[10.34.63.202:/mnt/export/nfs/lv2/pkubica/n7=<STORAGE_CONNECTION, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
2015-09-08 13:44:35,869 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] Running command: AddStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: SystemAction group CREATE_STORAGE_DOMAIN with role type ADMIN
2015-09-08 13:44:35,870 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] START, ConnectStorageServerVDSCommand(HostName = vhost7, StorageServerConnectionManagementVDSParameters:{runAsync='true', hostId='4fa4df6c-1478-4005-bb4f-72012e6b71f1', storagePoolId='00000000-0000-0000-0000-000000000000', storageType='NFS', connectionList='[StorageServerConnections:{id='null', connection='10.34.63.202:/mnt/export/nfs/lv2/pkubica/n7', iqn='null', vfsType='null', mountOptions='null', nfsVersion='V3', nfsRetrans='null', nfsTimeo='null', iface='null', netIfaceName='null'}]'}), log id: 5abf1e29
2015-09-08 13:44:35,951 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] FINISH, ConnectStorageServerVDSCommand, return: {00000000-0000-0000-0000-000000000000=100}, log id: 5abf1e29
2015-09-08 13:44:35,954 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-7) [76de72c0] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: The error message for connection 10.34.63.202:/mnt/export/nfs/lv2/pkubica/n7 returned by VDSM was: General Exception
2015-09-08 13:44:35,954 ERROR [org.ovirt.engine.core.bll.storage.BaseFsStorageHelper] (ajp-/127.0.0.1:8702-7) [76de72c0] The connection with details '10.34.63.202:/mnt/export/nfs/lv2/pkubica/n7' failed because of error code '100' and error message is: general exception
2015-09-08 13:44:35,954 ERROR [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] Command 'org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand' failed: EngineException: GeneralException (Failed with error GeneralException and code 100)
2015-09-08 13:44:35,958 ERROR [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] Transaction rolled-back for command 'org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand'.
2015-09-08 13:44:35,973 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-7) [76de72c0] Lock freed to object 'EngineLock:{exclusiveLocks='[10.34.63.202:/mnt/export/nfs/lv2/pkubica/n7=<STORAGE_CONNECTION, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
Comment 3 Petr Kubica 2015-09-08 08:18:05 EDT
Created attachment 1071328 [details]
vdsm-log
Comment 4 Petr Kubica 2015-09-08 08:18:38 EDT
Created attachment 1071329 [details]
engine-logs
Comment 5 Tal Nisan 2015-09-08 08:47:57 EDT

*** This bug has been marked as a duplicate of bug 1259310 ***

Note You need to log in before you can comment on or make changes to this bug.