Bug 1260618 - perl-Locale-Maketext-Gettext-1.28-2.fc24 FTBFS: t/00-signature.t fails
perl-Locale-Maketext-Gettext-1.28-2.fc24 FTBFS: t/00-signature.t fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Locale-Maketext-Gettext (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://ppisar.fedorapeople.org/perl_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 07:35 EDT by Petr Pisar
Modified: 2015-09-21 04:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Locale-Maketext-Gettext-1.28-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 04:45:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-07 07:35:25 EDT
perl-Locale-Maketext-Gettext-1.28-3.fc24 fails to build in F24:

+ ./Build test
WARNING: This key is not certified with a trusted signature!
Primary key fingerprint: 818A 7E1E 4DE3 FB39 C967  9C03 8BD8 2E6F 30B9 4B5C
--- SIGNATURE Sat Jun 27 03:20:05 2009
+++ (current) Sat Sep  5 21:01:21 2015
@@ -10,7 +10,7 @@
 SHA1 b699f73f5fa33123b2f4f1b210665e295900c74d README
 SHA1 3db402b52e04cf5a6e60291c23aac8c16f2db810 THANKS
 SHA1 85dd5ac895cc0a5b95827060999578d8ce8d41dd TODO
-SHA1 f9deac7b12cc6a3cb18b7f5282f9e6a1e1a624b9 lib/Locale/Maketext/Gettext.pm
+SHA1 681029b01c327edb3fe2df240fcd55190edab331 lib/Locale/Maketext/Gettext.pm
 SHA1 b88b6bad1e8cb0ba825594c233c006c1b297646f lib/Locale/Maketext/Gettext/Functions.pm
 SHA1 f89afd70fdcbaeeab44fada7ed3087d5c7f6f018 script/maketext
 SHA1 525f414c7a0aadc61240a4b0959ca2cda7514c75 t/00-signature.t
==> MISMATCHED content between SIGNATURE and distribution files! <==
t/00-signature.t ..... 
Failed 1/1 subtests 

The last commit:

 %clean
+# Disable signature tests since we patch the source
+rm -f SIGNATURE
 rm -rf $RPM_BUILD_ROOT

does not fix it because %clean section is performed after %check section.

Note You need to log in before you can comment on or make changes to this bug.