Bug 1260631 - fts fails to build on ppc64le
Summary: fts fails to build on ppc64le
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fts
Version: rawhide
Hardware: ppc64le
OS: Linux
low
unspecified
Target Milestone: ---
Assignee: Alejandro Alvarez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: epel7ppc64le
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-09-07 11:51 UTC by Rafael Fonseca
Modified: 2015-09-18 18:35 UTC (History)
3 users (show)

Fixed In Version: 3.3.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-18 18:35:14 UTC


Attachments (Terms of Use)

Description Rafael Fonseca 2015-09-07 11:51:38 UTC
Description of problem: fts fails to build on ppc64le with the following error:

checking build system type... /builddir/build/BUILD/fts-3.3.1/src/common/google-coredumper/config.guess: unable to guess system type

This script, last modified 2005-08-03, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
and
  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub

If the version you run (/builddir/build/BUILD/fts-3.3.1/src/common/google-coredumper/config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2005-08-03

uname -m = ppc64le
uname -r = 4.0.4-301.fc22.ppc64le
uname -s = Linux
uname -v = #1 SMP Thu May 21 08:15:04 MST 2015

/usr/bin/uname -p = ppc64le
/bin/uname -X     = 

hostinfo               = 
/bin/universe          = 
/usr/bin/arch -k       = 
/bin/arch              = ppc64le
/usr/bin/oslevel       = 
/usr/convex/getsysinfo = 

UNAME_MACHINE = ppc64le
UNAME_RELEASE = 4.0.4-301.fc22.ppc64le
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP Thu May 21 08:15:04 MST 2015
configure: error: cannot guess build type; you must specify one
src/common/CMakeFiles/libcoredumper.dir/build.make:59: recipe for target 'src/common/google-coredumper/Makefile' failed
make[2]: *** [src/common/google-coredumper/Makefile] Error 1
make[2]: Leaving directory '/builddir/build/BUILD/fts-3.3.1/build'
CMakeFiles/Makefile2:195: recipe for target 'src/common/CMakeFiles/libcoredumper.dir/all' failed
make[1]: *** [src/common/CMakeFiles/libcoredumper.dir/all] Error 2
make[1]: Leaving directory '/builddir/build/BUILD/fts-3.3.1/build'
Makefile:119: recipe for target 'all' failed
make: *** [all] Error 2

Looking into the config.guess file, you can see it fails because there is no case for ppc64le architecture, only for ppc and ppc64.

Version-Release number of selected component (if applicable): 3.3.1-1


How reproducible: ppc-koji build fts on ppc64le

Comment 1 Fedora Update System 2015-09-08 11:42:16 UTC
fts-3.3.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15093

Comment 2 Fedora Update System 2015-09-08 17:51:47 UTC
fts-3.3.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update fts'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15093

Comment 3 Fedora Update System 2015-09-18 18:35:02 UTC
fts-3.3.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.