Bug 1260690 - Copying Model to another Project
Copying Model to another Project
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 09:03 EDT by skaleta
Modified: 2016-02-05 05:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 05:30:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2640 Optional Open Copying Model to another Project 2016-08-09 01:16 EDT

  None (edit)
Description skaleta 2015-09-07 09:03:39 EDT
Description:
Is it OK, if its possible to create (source, view) model by copying from model in different project? 
I think it does not make sense to copy view model from one project to another.

Steps to Reproduce:
1. right-click on a project and select New > Teiid Metadata Model
2. select Module Builder: Copy from existing model of the same model class (rest is optional) and click Next >
3. browse for models and select a model that is not in right-clicked project
4. new model will be created in right-clicked project
Comment 1 Van Halbert 2015-09-07 09:21:11 EDT
It makes sense in the use case of top-down modeling.   The user is designer their abstraction layer first.   And then will work down to map the views to underlying layers (i.e., Object Layer) or to the actual source model.
Comment 2 Matus Makovy 2015-09-07 09:31:56 EDT
OK, but when you copy a view model that references some source model, TD should at least warn you that the resulting view model will be broken, in my opinion. (or copy referenced source model also)
Comment 3 Barry LaFond 2015-09-10 14:59:51 EDT
Pushing to DV 6.3 Tooling release
Comment 4 Matus Makovy 2016-02-05 05:30:58 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.

Note You need to log in before you can comment on or make changes to this bug.