Bug 1260723 - Copying Model problem
Copying Model problem
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 10:07 EDT by skaleta
Modified: 2016-09-29 07:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 05:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zip with tested project and pictures of bugs (111.87 KB, application/zip)
2015-09-07 10:07 EDT, skaleta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2641 Major Closed Copying Model problem 2016-09-29 19:25 EDT

  None (edit)
Description skaleta 2015-09-07 10:07:19 EDT
Created attachment 1071037 [details]
zip with tested project and pictures of bugs

Description:
When creating new view model by copying from existing model (see steps to reproduce), two bugs occurs.

First: 
In Transformation Diagram of model's procedures, name of model is not updated.
(see CopyModelProcedureSQL.png in attachement.zip)
In this case "Products_view.PRODUCTDATA.NAME" should be updated to 
"<new_model_name>.PRODUCTDATA.NAME", otherwise it produce validation error.

Additionally:
If location of new model is different from existing model (different folder or project), import declarations to source model will be added as following:
1. import declaration to source model is added (in this case: /Dataroles/sources/Products_source.xmi)
2. concurrently, another import declaration (with name: Model Import) with error (Unable to resolve the imported model ../sources/Products_source.xmi) is added.
(see CopyModelImports.png in attachement.zip)

Steps to Reproduce:
1. import attached project (TestedProject.zip in attachement.zip)
2. right-click on project and select New > Teiid Metadata Model
3. set new name and select Relational Model Class, View Model Type, Module Builder: "Copy from existing model of the same model class" and click Next >
4. browse for existing: <ImportedProjectName>/views/Products_view.xmi and click OK and Finish
5. new model will be created
Comment 1 skaleta 2015-09-09 09:09:52 EDT
Using Save As Model (double-click model - File->Save as.. - new location and name) causes same error in Transformation Diagram of model's procedures. (Import declarations are correct it this case)
Comment 2 Barry LaFond 2015-09-10 14:57:34 EDT
pushing to next DV 6.3 Tooling
Comment 3 JBoss JIRA Server 2016-01-04 08:02:58 EST
Paul Richardson <p.g.richardson@phantomjinx.co.uk> updated the status of jira TEIIDDES-2641 to Resolved
Comment 4 Matus Makovy 2016-02-05 05:32:50 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.
Comment 5 JBoss JIRA Server 2016-02-22 10:19:45 EST
stanislav kaleta <skaleta@redhat.com> updated the status of jira TEIIDDES-2641 to Closed
Comment 6 JBoss JIRA Server 2016-04-14 14:38:51 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2641 to Reopened
Comment 7 JBoss JIRA Server 2016-04-14 14:49:09 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2641 to Closed

Note You need to log in before you can comment on or make changes to this bug.