This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1260732 - [BACKWARDS COMPATIBILITY CLEANUP] Remove support for pinning VM to only one CPU
[BACKWARDS COMPATIBILITY CLEANUP] Remove support for pinning VM to only one CPU
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
---
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Juan Hernández
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 10:30 EDT by Juan Hernández
Modified: 2016-07-05 04:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45813 master MERGED restapi: Remove the capability to pin a VM to a single host Never

  None (edit)
Description Juan Hernández 2015-09-07 10:30:12 EDT
Version 3.6 introduced support for pinning a VM to multiple VMs, preserving the previous capability to pin to only one CPU. In 4.0 we should remove the old mechanism, as the new one is a super-set.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:57:13 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Juan Hernández 2016-04-06 08:18:50 EDT
Note that this has been removed from version 4 of the API, but preserved in version 3.
Comment 3 Artyom 2016-06-05 06:55:54 EDT
Verified on rhevm-4.0.0.2-0.1.el7ev.noarch
Update VM placement policy under v3:
<vm>
<placement_policy>
<host id="d4579633-f6a0-4e20-9e56-e5e58b403f4c"/>
</placement_policy>
</vm>
PASS
v4:
<vm>
<placement_policy>
<host id="d4579633-f6a0-4e20-9e56-e5e58b403f4c"/>
</placement_policy>
</vm>
FAILED
Comment 4 Sandro Bonazzola 2016-07-05 04:03:19 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.