Bug 1260757 - Hosted-engine notification not work
Hosted-engine notification not work
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.0-rc3
: 1.3.0
Assigned To: Simone Tiraboschi
Artyom
integration
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 12:07 EDT by Artyom
Modified: 2015-11-04 08:40 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:40:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
bmcclain: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46543 master MERGED setup: add default state transition notifications Never
oVirt gerrit 46544 master MERGED sharedconf: moving initial broker.conf to engine_ha_statedir Never
oVirt gerrit 46570 ovirt-hosted-engine-setup-1.3 MERGED setup: add default state transition notifications Never
oVirt gerrit 46601 ovirt-hosted-engine-ha-1.3 MERGED sharedconf: moving initial broker.conf to engine_ha_statedir Never

  None (edit)
Description Artyom 2015-09-07 12:07:34 EDT
Description of problem:
Hosted-engine broker notification not send emails

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-1.3.0-0.4.beta.git1bcfe28.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted engine and give your email as destination email
2. Change state of hosted-engine(hosted-engine --set-maintenance --mode=global)
3.

Actual results:
No email coming on email with notification about state change

Expected results:
Email about state change must come to email

Additional info:
I checked a little code, and from some reason we use file /var/lib/ovirt-hosted-engine-ha/broker.conf as configuration file for notification
cfg.read(constants.NOTIFY_CONF_FILE), when 
NOTIFY_CONF_FILE = '@ENGINE_HA_STATEDIR@/broker.conf'
but file /var/lib/ovirt-hosted-engine-ha/broker.conf looks like,
[email]
smtp-server = localhost
smtp-port = 25
source-email = root@localhost
destination-emails = alukiano@redhat.com
and do not have section
[notify]
state_transition=maintenance|start|stop|migrate|up|down

if I change cfg.read(constants.NOTIFY_CONF_FILE) to use file under /etc/ovirt-hosted-engine-ha/broker.conf all works as expected
also hosted-engine --deploy update file under /var/lib and not under /etc/
Comment 1 Red Hat Bugzilla Rules Engine 2015-09-22 04:26:35 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Artyom 2015-10-11 08:45:13 EDT
Verified on ovirt-hosted-engine-ha-1.3.0-1.el7ev.noarch
Comment 3 Sandro Bonazzola 2015-11-04 08:40:24 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.