Bug 1260792 - [RFE] packages selected for content view should include dependent packages regardless of filters [NEEDINFO]
[RFE] packages selected for content view should include dependent packages re...
Status: CLOSED DUPLICATE of bug 1152515
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.1
x86_64 Linux
urgent Severity high (vote)
: 6.1.z
: 6.1
Assigned To: satellite6-bugs
: FutureFeature, PrioBumpGSS, Triaged
Depends On:
Blocks: 1316897
  Show dependency treegraph
 
Reported: 2015-09-07 15:33 EDT by Fred van Zwieten
Modified: 2017-07-26 15:43 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-09 11:22:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dmoessne: needinfo? (satellite6-bugs)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 2478 Normal NEW Support more conservative dependency solving 2016-12-07 21:00 EST

  None (edit)
Description Fred van Zwieten 2015-09-07 15:33:10 EDT
Description of problem:
Currently, packages selected for inclusion into a content view during publish do not include dependent packages which is a big annoyance because this dependency checking must now be done manually which is a lot of work, especially if it is a multilevel dependency.

Version-Release number of selected component (if applicable):


How reproducible:

6.
Steps to Reproduce:
example:
1. create content view with rhel 7Server
2. create include filter on all base packages
3. create include filter on errata up to 1-apr-2015
4. create include filter on package redhat-access-insights
5. publish & promote contentview
6. subscribe content host to this content views repo's
7. try to install redhat-access-insights
8. look at dependency errors and try to resolve based on info
9. keep doning until all dependencies are resolved.

Actual results:
yum dependency errors

Expected results:
able to install packages with all dependencies resolved

Additional info:
If dependency cannot be resolved due to missing dependent packages in included repo's the publish task should fail with a clear explanation why it failed.
Comment 12 Bryan Kearney 2016-07-08 16:18:52 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 20 pulp-infra@redhat.com 2016-12-07 21:00:58 EST
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 21 pulp-infra@redhat.com 2016-12-07 21:01:05 EST
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Note You need to log in before you can comment on or make changes to this bug.