Bug 1260805 - [DOCS] [3.1] [Feature] Document in detail HA Setup for OSE 3.1
[DOCS] [3.1] [Feature] Document in detail HA Setup for OSE 3.1
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Alex Dellapenta
Ma xiaoqiang
Vikram Goyal
:
: 1269367 (view as bug list)
Depends On:
Blocks: 1270113
  Show dependency treegraph
 
Reported: 2015-09-07 18:51 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 12:55:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-09-07 18:51:50 EDT
Email from Ali Sogukpinar, OSE SME:

=====
Yes, I think we need extend our existing  documentation for HA setup. As
you can see from case, customer was planning to deploy OSE to multiple
data centers.  For such a setup there are things to be considered. Maybe
specifics of such a setup is not in scope of the OSE however, we need to
list things customer needs to consider when they do such a setup.

Such as; they need to have at least 3 Etcd nodes and if they have
multiple datacenters then they need to have odd number of location, if
they have 2 datacenters and one datacenter is in maintenance they will
lose majority hence, Etcd will stop functioning.

Also for HA setup, we don't have any setup documentation. Customer asked
me documentation for setting up Etcd and masters in HA configuration.
They didn't know if we need use ansible scripts or they need to do it
manually. I didn't have chance myself yet to setup such a configuration
however, I think this needs to be part of our documentation.

Please let me know if you have any further questions.

====

Also, see the attached case.
Comment 6 Vikram Goyal 2015-10-29 23:48:06 EDT
*** Bug 1269367 has been marked as a duplicate of this bug. ***
Comment 7 Alex Dellapenta 2015-11-05 23:13:34 EST
Initial docs PR for new 3.1 HA setup docs here:

https://github.com/openshift/openshift-docs/pull/1046

Working on building off that commit. The openshift-ansible PR has merged now as well today:

https://github.com/openshift/openshift-ansible/pull/608
Comment 8 openshift-github-bot 2015-11-11 10:38:32 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/9b8dca1cacb1956c2ad6b20efbeb53373e2c0d63
Merge pull request #1170 from adellape/native_ha_install

Bug 1260805: HA install updates for 3.1 (native/pacemaker)
Comment 9 Alex Dellapenta 2015-11-12 17:45:27 EST
3.1 Preview docs have been updated to include info on new HA master changes (e.g., native HA) and install (Advanced Installation method only):

https://docs.openshift.com/enterprise/3.1/install_config/install/advanced_install.html

https://docs.openshift.com/enterprise/3.1/architecture/infrastructure_components/kubernetes_infrastructure.html
Comment 10 Johnny Liu 2015-11-16 03:45:20 EST
About master HA, most are correct. But the following still need more polish.

1. In "Table 2. Availability Matrix with HAProxy", "Virtual IP" is redundant which is only used for pacemaker HA.

2. In "Table 2. Cluster Variables " and "Table 3. Availability Matrix with Pacemaker", about "cluster_vip" or "Virtual IP", we should prompt user that, "Virtual IP" for pacemaker HA will be assigned to active master automatically, so the IP must be available in cluster network, and this IP should be able to communicate with any other masters, etcd, and nodes's IP. they should be in the same network.
Comment 12 Johnny Liu 2015-11-16 21:03:45 EST
Verified and PASS.
Comment 13 Alex Dellapenta 2015-11-19 13:05:33 EST
Published in the following topics, updated for new native HA method and other OSE 3.1 changes wrt multiple masters:

https://docs.openshift.com/enterprise/latest/install_config/install/advanced_install.html

https://docs.openshift.com/enterprise/latest/architecture/infrastructure_components/kubernetes_infrastructure.html#high-availability-masters

Note You need to log in before you can comment on or make changes to this bug.