Bug 1260866 - rhcert listener doesn't start for tool which is used for Citrix LBaas agent certificartion
rhcert listener doesn't start for tool which is used for Citrix LBaas agent ...
Status: CLOSED DUPLICATE of bug 1181296
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 02:00 EDT by Deepika Khairnar
Modified: 2015-10-28 09:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-28 09:17:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached file contains all steps followed while installation of tool (15.20 KB, application/rtf)
2015-09-08 02:00 EDT, Deepika Khairnar
no flags Details

  None (edit)
Description Deepika Khairnar 2015-09-08 02:00:21 EDT
Created attachment 1071199 [details]
Attached file contains all steps followed while installation of tool

Description of problem:
rhcert listener daemon does not  start


Version-Release number of selected component (if applicable):
redhat-certification-openstack-1.0.0-1.el7.noarch

How reproducible:
Every time getting same issue 

Steps to Reproduce:
1.install redhat-certification
2.rhcert-backend server start --debug=high
 rhcert-backend server listener --debug=high
3. Check logs 

Actual results:


Expected results:
listener starts instead of resulting in a traceback.

Additional info:
# rhcert-backend server status
registered Test from rhcert.test
The rhcert daemon is running
The rhcert listener is NOT running

Additional info:
Searching /usr/lib/python2.7/site-packages/rhcert/suites...
sys.path:
['/usr/bin', '/usr/lib64/python27.zip', '/usr/lib64/python2.7', '/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', '/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', '/usr/lib64/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/gtk-2.0', '/usr/lib/python2.7/site-packages', u'/usr/lib/python2.7/site-packages/rhcert/suites']
importing suite openstack as module
Skipping class <class 'rhcert.test.Test'> - constructor takes 2 args
Skipping class <class 'rhcert.test.UnitTest'> - constructor takes 5 args
Skipping class <class 'openstack.base.OpenStackTest'> - constructor takes 2 args
Instantiated test class <class 'openstack.verify.OpenStackVerifyTest'>

Starting RedHatCertDaemon at 2015-09-07 11:47:52
The rhcert daemon is already started
The rhcert listener is running
Stopping rhcert listener
Starting listener
Traceback (most recent call last):
  File "/usr/bin/rhcert-backend", line 37, in <module>
    success = rhcertBackend.do(args)
  File "/usr/lib/python2.7/site-packages/rhcert/client/backend.py", line 180, in do
    return self.doServer(args)
  File "/usr/lib/python2.7/site-packages/rhcert/client/backend.py", line 224, in doServer
    return listener.run()
  File "/usr/lib/python2.7/site-packages/rhcert/listener/listen.py", line 123, in run
    allow_none=True)
  File "/usr/lib64/python2.7/SimpleXMLRPCServer.py", line 593, in __init__
    SocketServer.TCPServer.__init__(self, addr, requestHandler, bind_and_activate)
  File "/usr/lib64/python2.7/SocketServer.py", line 419, in __init__
    self.server_bind()
  File "/usr/lib64/python2.7/SocketServer.py", line 430, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib64/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
socket.error: [Errno 98] Address already in use
Comment 4 Greg Nichols 2015-10-28 09:17:52 EDT

*** This bug has been marked as a duplicate of bug 1181296 ***

Note You need to log in before you can comment on or make changes to this bug.