Bug 1260878 - Running salt command on a freshly installed calamari node fails
Running salt command on a freshly installed calamari node fails
Status: CLOSED NOTABUG
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity medium
: rc
: 1.3.3
Assigned To: Gregory Meno
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 03:04 EDT by shylesh
Modified: 2017-12-12 19:23 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 15:12:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2015-09-08 03:04:06 EDT
According to install document for 1.3.1 https://gitlab.cee.redhat.com/jowilkin/red-hat-ceph-storage-installation-guide-rhel/blob/v1.3/calamari.adoc in the "Initialize calamari " section it says to run "
sudo salt '*' state.highstate" command . But this command is not run successfully.


 
[ceph@hp-ms-01-c42 ~]$ sudo salt '*' state.highstate
No minions matched the target. No command was sent, no jid was assigned.



According to the bug https://bugzilla.redhat.com/show_bug.cgi?id=1223335#c8 this command is required for only upgrades but I could see this command in install doc as well.

Can somebody clarify this ??
Comment 2 Gregory Meno 2016-02-05 15:12:46 EST
This is the expected result. If there are no configured calamari-agents(salt-minion)

Not a bug.

Note You need to log in before you can comment on or make changes to this bug.