Bug 1260937 - [RFE] New Command line flag --output-rsync to generate output file ready to consumed by Rsync
Summary: [RFE] New Command line flag --output-rsync to generate output file ready to c...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-08 09:26 UTC by Aravinda VK
Modified: 2018-11-19 05:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 05:20:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 569 0 None None None 2018-11-19 05:53:45 UTC

Description Aravinda VK 2015-09-08 09:26:29 UTC
Description of problem:

New option to glusterfind to generate rsync ready output file, so that we can avoid post processing.

For example,

    glusterfind pre backup homegfs ~/out.txt --outfile-rsync

Then you can use rsync as

    rsync -0 --files-from=~/out.txt SRC/ DEST/

Note: -0 is required since outfile is delimited by \0 instead of new line.

Comment 1 Vijay Bellur 2018-11-19 05:39:17 UTC
Migrated to github:

https://github.com/gluster/glusterfs/issues/569

Please follow the github issue for further updates on this bug.


Note You need to log in before you can comment on or make changes to this bug.