Bug 1260994 - xen: virsh doesn't list VMs created outside of libvirt by native xl toolstack
xen: virsh doesn't list VMs created outside of libvirt by native xl toolstack
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 07:29 EDT by Andreas Pflug
Modified: 2016-03-22 07:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 07:39:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Pflug 2015-09-08 07:29:48 EDT
Description of problem:
virsh list doesn't list all domains. Specifically, all domains not created through virsh aren't listed. This includes dom0, which is created by the hypervisor at startup, and other domains created with xl.

Version-Release number of selected component (if applicable):
libvirt 1.2.9, Xen 4.4.1

How reproducible:
"virsh list" on a xen dom0 with the xl toolstack configured.

Steps to Reproduce:
Using the xl toolstack (preferred since Xen 4.1, only toolstack since Xen 4.5)


Actual results:
Only virsh/libvirt-created doms are shown

Expected results:
see all domains

Additional info:
Apparently by design, as a blog post of the xenlight driver creator suggests. The driver really should get its information from the hypervisor and the toolstack, not use some cached data which may be outdated for many reasons.
Comment 1 Cole Robinson 2016-03-21 18:30:16 EDT
Can you link to the blogpost you mention?
Comment 3 Cole Robinson 2016-03-22 07:39:37 EDT
Thank you Andreas. Indeed it sounds like this was a deliberate design decision though Jim doesn't elaborate in his blog post.

Most of the xen devs don't follow this tracker so you won't get much of a response here unfortunately... my guess is this bug is WONTFIX from their end. I suggest mailing libvir-list and ccing jfehlig@suse.com asking about the design decision and if it's ever going to change. If so then we can consider re-opening this bug

Note You need to log in before you can comment on or make changes to this bug.