Bug 1260999 - efibootmgr: EFI variables are not supported on this system.
efibootmgr: EFI variables are not supported on this system.
Status: CLOSED DUPLICATE of bug 1260799
Product: Fedora
Classification: Fedora
Component: efibootmgr (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-09-08 07:47 EDT by Lukas Brabec
Modified: 2015-10-12 07:26 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 14:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program.log (152.91 KB, text/plain)
2015-09-08 07:47 EDT, Lukas Brabec
no flags Details
dmesg from a UEFI VM reproducer (51.55 KB, text/plain)
2015-09-08 14:14 EDT, Adam Williamson
no flags Details

  None (edit)
Description Lukas Brabec 2015-09-08 07:47:14 EDT
Created attachment 1071303 [details]
program.log

Description of problem:
I tried to install F23 Beta TC4 on UEFI machine. The installation went fine until boot loader installation, which failed with error message:

"""
The following error occurred while installing the boot loader. The system will not be bootable. Would you like to ignore this and continue with installation?

failed to set new efi boot target. This is most likely a kernel of firmware bug
"""

Checked dd and livecd-iso-to-disk creation method, occurs on both.


Version-Release number of selected component:
anaconda 23.19.2-1
efibootmgr 0.12
kernel 4.2.0-1


Steps to Reproduce:
1. create installation media usable on UEFI machine
2. boot a do default install
3. boot loader fails to install
Comment 1 Kamil Páral 2015-09-08 09:16:48 EDT
This is the relevant part of the log:

14:23:49,005 INFO program: Running... efibootmgr
14:23:49,017 INFO program: efibootmgr: EFI variables are not supported on this system.
14:23:49,017 DEBUG program: Return code: 2
14:23:49,018 INFO program: Running... efibootmgr -c -w -L Fedora -d /dev/sda -p 1 -l \EFI\fedora\shim.efi
14:23:49,031 INFO program: efibootmgr: EFI variables are not supported on this system.
14:23:49,032 DEBUG program: Return code: 2

However, Lukas forgot to mention that if you switch to VT2 and run "efibootmgr", it prints current boot options just fine. So there seems to be some difference between running it in a VT and anaconda running it inside its process (in a chroot?).

Lukas, can you please test on a different UEFI system as well, and if it happens on both, propose this as a blocker? Thanks.
Comment 2 Lukas Brabec 2015-09-08 09:31:18 EDT
I just tried it on another machine and it is there, the same error.
Comment 3 Fedora Blocker Bugs Application 2015-09-08 09:49:16 EDT
Proposed as a Blocker for 23-beta by Fedora user lbrabec using the blocker tracking app because:

  I propose this as an Beta blocker using this criterion:
As previously proposed by kparal in https://bugzilla.redhat.com/show_bug.cgi?id=1235323#c10, and because it presumably violates Beta criterion:
Any installation method or process designed to run unattended must do so. There should be no prompts requiring user intervention.
https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Unattended_installation

Despite the error alert, the system booted as expected, however, I'm not sure whether it wasn't caused by previous fedora installation and efi fallback.
Comment 4 Adam Williamson 2015-09-08 13:54:39 EDT
J.A. Watson reported UEFI boot manager failure to me via email, so I suspect he's hitting this and it's indeed a general issue in anaconda/efibootmgr, not a system-specific firmware problem.
Comment 5 David Shea 2015-09-08 14:03:57 EDT
Can you attach the dmesg output? This looks like it may be the same things as bug 1260799.
Comment 6 Adam Williamson 2015-09-08 14:09:52 EDT
I also reproduced this in a UEFI VM. +1 blocker for me - fallback will sometimes save us, but not always.

For F24 (F23 is string frozen) we might want to change "will not be bootable" to "may not be bootable" here?
Comment 7 Adam Williamson 2015-09-08 14:14:13 EDT
Created attachment 1071442 [details]
dmesg from a UEFI VM reproducer

Here's the 'dmesg' after booting the TC4 installer on a UEFI VM.
Comment 8 David Shea 2015-09-08 14:25:05 EDT
Looks like the same thing: the kernel is creating /sys/firmware/efi, but for whatever reason it's not finding the EFI memory map, so /sys/firmware/efi/efivars never gets mounted.

*** This bug has been marked as a duplicate of bug 1260799 ***

Note You need to log in before you can comment on or make changes to this bug.