Bug 1261002 - ValueError: Group users already exists
ValueError: Group users already exists
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:a5437f8fc527f0c47c4b0b8df72...
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-09-08 07:59 EDT by Joachim Frieben
Modified: 2015-10-19 12:46 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-23.19.6-1 anaconda-23.19.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-10 18:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.30 MB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: anaconda.log (63.49 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: dnf.log (164.25 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: dnf.rpm.log (178.64 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: environ (459 bytes, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: lsblk_output (2.46 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: nmcli_dev_list (1.96 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: storage.log (178.86 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: syslog (142.74 KB, text/plain)
2015-09-08 07:59 EDT, Joachim Frieben
no flags Details
File: ifcfg.log (2.75 KB, text/plain)
2015-09-08 08:00 EDT, Joachim Frieben
no flags Details
File: packaging.log (1.47 KB, text/plain)
2015-09-08 08:00 EDT, Joachim Frieben
no flags Details
File: program.log (158.29 KB, application/octet-stream)
2015-09-08 08:00 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2015-09-08 07:59:19 EDT
Description of problem:
At the end of the install procedure during the creation of the user account.

Version-Release number of selected component:
anaconda-23.19.2-1

The following was filed automatically by anaconda:
anaconda 23.19.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/users.py", line 211, in createGroup
    raise ValueError("Group %s already exists" % group_name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 728, in execute
    users.createGroup(grp.name, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 95, in doConfiguration
    ksdata.group.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
ValueError: Group users already exists

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23_B_T4-x86_64 rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-1.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Joachim Frieben 2015-09-08 07:59:37 EDT
Created attachment 1071308 [details]
File: anaconda-tb
Comment 2 Joachim Frieben 2015-09-08 07:59:39 EDT
Created attachment 1071309 [details]
File: anaconda.log
Comment 3 Joachim Frieben 2015-09-08 07:59:43 EDT
Created attachment 1071310 [details]
File: dnf.log
Comment 4 Joachim Frieben 2015-09-08 07:59:47 EDT
Created attachment 1071311 [details]
File: dnf.rpm.log
Comment 5 Joachim Frieben 2015-09-08 07:59:48 EDT
Created attachment 1071312 [details]
File: environ
Comment 6 Joachim Frieben 2015-09-08 07:59:49 EDT
Created attachment 1071313 [details]
File: lsblk_output
Comment 7 Joachim Frieben 2015-09-08 07:59:51 EDT
Created attachment 1071314 [details]
File: nmcli_dev_list
Comment 8 Joachim Frieben 2015-09-08 07:59:52 EDT
Created attachment 1071315 [details]
File: os_info
Comment 9 Joachim Frieben 2015-09-08 07:59:55 EDT
Created attachment 1071316 [details]
File: storage.log
Comment 10 Joachim Frieben 2015-09-08 07:59:58 EDT
Created attachment 1071317 [details]
File: syslog
Comment 11 Joachim Frieben 2015-09-08 08:00:00 EDT
Created attachment 1071318 [details]
File: ifcfg.log
Comment 12 Joachim Frieben 2015-09-08 08:00:01 EDT
Created attachment 1071319 [details]
File: packaging.log
Comment 13 Joachim Frieben 2015-09-08 08:00:04 EDT
Created attachment 1071320 [details]
File: program.log
Comment 14 David Shea 2015-09-08 12:56:36 EDT
What steps did you take leading up to the crash? What options did you set when creating a user?
Comment 15 Joachim Frieben 2015-09-08 18:04:33 EDT
(In reply to David Shea from comment #14)
The crash was triggered by adding the group "users" when creating the new user.
Comment 16 Joachim Frieben 2015-09-11 07:23:01 EDT
This issue was absent from anaconda-23.19.1-1.fc23 as included in Fedora 23 Beta TC1.
Comment 17 Joachim Frieben 2015-09-12 15:16:15 EDT
Another user experienced a similar problem:

I added "users" as additional group for the new user.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23_B_T5-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
package:        anaconda-23.19.3-1
product:        Fedora
reason:         ValueError: Group users already exists
release:        Cannot get release name.
version:        23
Comment 18 Fedora Blocker Bugs Application 2015-09-16 12:08:27 EDT
Proposed as a Freeze Exception for 23-final by Fedora user dshea using the blocker tracking app because:

 There doesn't appear to be anything in the criteria about user creation, but this is pretty severe change in behavior. This crash will affect any install that attempts to add a user to an existing system group, both interactive and kickstart installs.
Comment 19 Marcin Juszkiewicz 2015-09-21 06:42:04 EDT
[anaconda root@localhost tmp]# anaconda --version
anaconda 23.19.3-1

Tested f23/aarch64 instalation. New user added to 'wheel, mock' groups and instalation failed in same way:

12:29:09,375 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)

  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 95, in doConfiguration
    ksdata.group.execute(storage, ksdata, instClass, u)

  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 728, in execute
    users.createGroup(grp.name, **kwargs)

  File "/usr/lib64/python3.4/site-packages/pyanaconda/users.py", line 211, in createGroup
    raise ValueError("Group %s already exists" % group_name)

ValueError: Group mock already exists

12:29:09,376 DEBUG anaconda: Gtk running, queuing exception handler to the main loop
Comment 20 Marcin Juszkiewicz 2015-09-21 06:43:44 EDT
System got installed and is in bootable state. Just no user created.
Comment 21 Jeff Bastian 2015-09-24 13:54:55 EDT
Another user experienced a similar problem:

I created an administrator user and tried to add it to both the wheel and systemd-journal groups.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23_B-x86_64 quiet
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
package:        anaconda-23.19.4-1
product:        Fedora
reason:         ValueError: Group systemd-journal already exists
release:        Cannot get release name.
version:        23
Comment 22 Egor Zaharov 2015-09-25 19:00:05 EDT
Another user experienced a similar problem:

This happens when you specify GID in brackets to a group which already exists.
But this brackets should be considered only if group does not exist.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23_B-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
package:        anaconda-23.19.4-1
product:        Fedora
reason:         ValueError: Group users already exists
release:        Cannot get release name.
version:        23
Comment 23 Adam Williamson 2015-09-28 18:13:00 EDT
Discussed at 2015-09-28 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-28/f23-blocker-review.2015-09-28-16.01.html . Accepted as a freeze exception issue, this is a noticeable installer bug that can't be fixed with an update, and should be fixable quite safely.
Comment 24 Alexandr 2015-10-02 12:38:22 EDT
Another user experienced a similar problem:

tried to install fedora23 cinnamon beta on VirtualBox 4.3.26. I have chosed to add user into additional groups: plugdev,netdev,audio,video. And on Creating users this error appeared

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Cinnamon-x86_64-23_B rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.4-1.fc23.x86_64
product:        Fedora
reason:         ValueError: Group audio already exists
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 25 Fedora Update System 2015-10-08 14:22:34 EDT
python-blivet-1.12.6-1.fc23 anaconda-23.19.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 26 Fedora Update System 2015-10-09 09:54:56 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 27 Fedora Update System 2015-10-12 02:27:03 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 28 Stéphane Gourichon 2015-10-16 13:42:01 EDT
Another user experienced a similar problem:

Just ran installer. USB created with dd. Had to boot in low grahics mode, probably because of bumblebee. Still 1920x1080. Partition existed, added extra existing partition at custom mount point. All in all, nothing special.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Xfce-x86_64-23_B-1 ro rd.live.image quiet rhgb nomodeset
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.4-1.fc23.x86_64
product:        Fedora
reason:         ValueError: Group dialout already exists
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 29 Adam Williamson 2015-10-16 15:02:09 EDT
The fix for this landed after Beta. You should find that it works in Final TC/RC builds, which you can read about on test@ and find at https://dl.fedoraproject.org/pub/alt/stage/ . Thanks for the report!
Comment 30 Stéphane Gourichon 2015-10-19 12:46:33 EDT
Thanks @awilliam. Re-ran the installer labelled TC11.
(Had to use basic graphics mode again, which is a different issue.)
Asked again to add user to group "dialout". Issue not reproduced, confirming the "close" status.
Thank you for your attention.

Note You need to log in before you can comment on or make changes to this bug.