Bug 1261004 - [New] - status and status information for geo-replication volume status service is not shown correctly when all the geo-rep sessions are deleted.
[New] - status and status information for geo-replication volume status servi...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS 3.1.2
Assigned To: Sahina Bose
Triveni Rao
: Regression, ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-09-08 08:05 EDT by RamaKasturi
Modified: 2016-05-16 00:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: gluster-nagios-common-0.2.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:11:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for status and status infromation when all the geo-rep sessions are deleted (256.01 KB, image/png)
2015-09-08 08:07 EDT, RamaKasturi
no flags Details
geo-rep status screen shot (186.11 KB, image/png)
2015-11-19 09:10 EST, Triveni Rao
no flags Details

  None (edit)
Description RamaKasturi 2015-09-08 08:05:08 EDT
Description of problem:
When all the geo-rep sessions from a volume are deleted, status and status information shows "WARNING" with Geo replication status could not be determined .<Cli ouput>.Attached is the screenshot.

Version-Release number of selected component (if applicable):
nagios-server-addons-0.2.2-1.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set Up a geo-rep session and start it.
2. Now stop the geo-rep session and delete it.
3.

Actual results:
geo-replication volume status service shows status as WARNING with status information as "Geo Replication status could not be determined. <cliOuput>

Expected results:
verify that geo-replication volume status service shows status as **OK** with status information as **Session status :No active sessions found**

Additional info:
Comment 2 RamaKasturi 2015-09-08 08:07:29 EDT
Created attachment 1071322 [details]
screenshot for status and status infromation when all the geo-rep sessions are deleted
Comment 9 Sahina Bose 2015-10-28 07:40:38 EDT
http://review.gluster.org/#/c/12441/ - posted to handle case when no sessions are present.
Comment 10 Triveni Rao 2015-11-19 09:10 EST
Created attachment 1096692 [details]
geo-rep status screen shot
Comment 11 Triveni Rao 2015-11-19 09:10:59 EST
This bug is verified with buil no 67:

Steps followed:
1. created geo-rep session between master and slave vols.
2. Started the session.
3. checked the status
4. Stopped the geo-rep session.
5. Deleted the geo-rep session.
6. On UI found that status of the session shows as no active sessions found which is expected.

Attached the screen shot.
Comment 13 errata-xmlrpc 2016-03-01 01:11:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.