Bug 1261013 - rhevm-sdk-java rpm doesn't require commons-logging-eap6 as dependency
rhevm-sdk-java rpm doesn't require commons-logging-eap6 as dependency
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-java (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Juan Hernández
Karolína Hajná
: Automation, AutomationBlocker, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 08:28 EDT by Lukas Bednar
Modified: 2016-05-19 21:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhevm-sdk-java-3.6.0.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:35:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Bednar 2015-09-08 08:28:24 EDT
Description of problem:

rhevm-skd-java rpm doesn't bring commons-logging-eap6 as dependency.
user can not use this lib without this package.

Version-Release number of selected component (if applicable):

rhevm-sdk-java-3.6.0.0-1.el6ev.noarch rpm

How reproducible:
100%

Steps to Reproduce:

yum install rhevm-sdk-java -y
rpm -qR rhevm-sdk-java | grep logging

try to use org.ovirt.engine.sdk.Api in java program

Actual results:

it fails to find LogFactory class

java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
	at org.apache.http.conn.ssl.AbstractVerifier.<init>(AbstractVerifier.java:89)
	at org.apache.http.conn.ssl.AllowAllHostnameVerifier.<init>(AllowAllHostnameVerifier.java:40)
	at org.apache.http.conn.ssl.SSLSocketFactory.<clinit>(SSLSocketFactory.java:145)
	at org.ovirt.engine.sdk.web.ConnectionsPoolBuilder.createSchemeRegistry(Unknown Source)
	at org.ovirt.engine.sdk.web.ConnectionsPoolBuilder.createPoolingClientConnectionManager(Unknown Source)
	at org.ovirt.engine.sdk.web.ConnectionsPoolBuilder.createDefaultHttpClient(Unknown Source)
	at org.ovirt.engine.sdk.web.ConnectionsPoolBuilder.build(Unknown Source)
	at org.ovirt.engine.sdk.Api.<init>(Unknown Source)
	at org.ovirt.engine.sdk.Api.<init>(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 9 more


Expected results:
it should bring commons-logging-eap6 rpm as dependency.

Additional info (Juan):
the commons-logging dependency isn't directly used by the SDK, but by the HTTP client, so it should be pulled by the httpcore-eap6 RPM, but it isn't.
Comment 1 Juan Hernández 2015-09-24 05:22:09 EDT
Note that there isn't a commons-logging-eap6 package, only jakarta-commons-logging. The SDK has been required to require it.
Comment 2 Karolína Hajná 2015-09-24 05:30:06 EDT
Verified on rhevm 3.6.0-12

Note You need to log in before you can comment on or make changes to this bug.