Bug 1261022 - .eot, .svg and .woff files missing
.eot, .svg and .woff files missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: google-roboto-fonts (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 08:46 EDT by Matthias Runge
Modified: 2016-11-22 09:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-22 09:08:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2015-09-08 08:46:16 EDT
Description of problem:

I would need those files for a requirement in OpenStack Dashboard.
Version-Release number of selected component (if applicable):
Comment 1 David Tardon 2015-09-08 13:22:34 EDT
The source zip that I use does not contain them. If you know a way to get a tarball from the Google Fonts site--or from anywhere else--that is both stable--i.e., won't change silently if the fonts are updated--and contains all the typefaces in all 4 formats, I will consider this. Otherwise, bad luck...
Comment 2 Nicolas Mailhot 2015-09-08 13:48:31 EDT
(In reply to Matthias Runge from comment #0)
> Description of problem:
> 
> I would need those files for a requirement in OpenStack Dashboard.
> Version-Release number of selected component (if applicable):

Then that's a bit of pointless cargo culting by openstack since no browser that matters actually needs a font format other than opentype for floss fonts nowadays (and that has been the case for quite a long time)

And I'm pretty sure legacy browsers won't pass tls negociation anyway given how fast people are deprecating old ciphers and ssl modes 

http://caniuse.com/ttf

Just say no, as fedora packaging guidelines do. Browsers that can not use opentype web fonts can live without them, not worth the pain of fat font rpms or having to investigate which format was broken during conversion when people report problems.
Comment 3 Matthias Runge 2015-09-09 02:48:52 EDT
I have been pointed to https://github.com/choffmeister/roboto-fontface-bower

Nicolas, can you please point me to the packaging guidelines location, where it says, carrying ttf is forbidden?
Comment 4 Jan Kurik 2016-02-24 08:44:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 David Tardon 2016-11-22 09:08:21 EST
We switched to https://github.com/google/roboto , which does regular releases. But it only ships .ttf in the release tarball.

Note You need to log in before you can comment on or make changes to this bug.