Bug 1261024 - Cannot use driverdisk from http
Cannot use driverdisk from http
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Shea
Release Test Team
:
: 1270227 (view as bug list)
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2015-09-08 08:50 EDT by Shaohui Deng
Modified: 2017-02-09 03:56 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.78-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (18.67 KB, image/png)
2015-09-08 08:51 EDT, Shaohui Deng
no flags Details
screenshot2 (31.02 KB, image/png)
2015-09-08 08:51 EDT, Shaohui Deng
no flags Details
screenshot3 (37.90 KB, image/png)
2015-09-08 08:51 EDT, Shaohui Deng
no flags Details
rdsosreport (71.96 KB, text/plain)
2015-09-08 08:52 EDT, Shaohui Deng
no flags Details
journal.log (65.21 KB, text/plain)
2015-09-08 08:52 EDT, Shaohui Deng
no flags Details
journalctl.log (3.42 MB, text/plain)
2015-09-09 02:52 EDT, Shaohui Deng
no flags Details
rdsosreport.txt (3.41 MB, text/plain)
2015-09-09 02:53 EDT, Shaohui Deng
no flags Details

  None (edit)
Description Shaohui Deng 2015-09-08 08:50:16 EDT
Description of problem:
I got "cat: /tmp/dd_disk: No such file or directory" error when I ran DUP during installation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. I add "inst.dd=http://***.iso" option to kernel cmd line before installation.
2. Got some error msg and then dracut timeout brings me into dracut shell.

3.

Actual results:


Expected results:


Additional info:
Comment 1 Shaohui Deng 2015-09-08 08:51:09 EDT
Created attachment 1071338 [details]
screenshot1
Comment 2 Shaohui Deng 2015-09-08 08:51:32 EDT
Created attachment 1071339 [details]
screenshot2
Comment 3 Shaohui Deng 2015-09-08 08:51:55 EDT
Created attachment 1071340 [details]
screenshot3
Comment 4 Shaohui Deng 2015-09-08 08:52:25 EDT
Created attachment 1071341 [details]
rdsosreport
Comment 5 Shaohui Deng 2015-09-08 08:52:53 EDT
Created attachment 1071342 [details]
journal.log
Comment 8 David Shea 2015-09-08 10:38:53 EDT
Please boot with rd.debug=1 and attach the logs from that.
Comment 9 Shaohui Deng 2015-09-09 02:52:15 EDT
Created attachment 1071582 [details]
journalctl.log
Comment 10 Shaohui Deng 2015-09-09 02:53:35 EDT
Created attachment 1071583 [details]
rdsosreport.txt
Comment 11 Shaohui Deng 2015-09-09 02:54:43 EDT
(In reply to David Shea from comment #8)
> Please boot with rd.debug=1 and attach the logs from that.

I uploaded two logs with rd.debug=1.

Thank you.
Comment 12 David Shea 2015-09-22 11:05:13 EDT
The inst.dd=http://... parameter is not automatically activating the network like other network-dependent installer parameters. If you add "ip=dhcp" or another network parameter to the kernel command line it should work.
Comment 14 David Shea 2016-05-26 15:28:12 EDT
*** Bug 1270227 has been marked as a duplicate of this bug. ***
Comment 15 David Shea 2016-05-27 08:28:43 EDT
Whoops, missed that there's already a PR open for this. https://github.com/rhinstaller/anaconda/pull/535
Comment 19 errata-xmlrpc 2016-11-03 19:11:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.