Bug 1261035 - [RFE] Allow alarm history to be deleted
[RFE] Allow alarm history to be deleted
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Yurii Prokulevych
http://specs.openstack.org/openstack/...
FutureFeature
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 09:07 EDT by Eoghan Glynn
Modified: 2016-04-07 17:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-aodh-1.0.0-3.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:07:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2015-09-08 09:07:26 EDT
Previously the records of alarm history were never expired, leading potentially to database bloat where there was a lot of churn on the alarm state.

It would be more convenient for alarm history records to be configurably expired via the usual TTL-style config option.
Comment 3 Jon Schlueter 2015-11-18 13:46:48 EST
blueprint appears to be marked as completed https://blueprints.launchpad.net/ceilometer/+spec/delete-alarmhistory
Comment 5 Yurii Prokulevych 2016-03-09 10:22:12 EST
Verified according test plan with aodh*-1.1.2-1.el7ost.noarch
Comment 7 errata-xmlrpc 2016-04-07 17:07:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.