Bug 1261046 - [RFE] Gather Total RAM Buffered and Total Cached Memory SNMP metrics
[RFE] Gather Total RAM Buffered and Total Cached Memory SNMP metrics
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
low Severity low
: beta
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Yurii Prokulevych
https://blueprints.launchpad.net/ceil...
FutureFeature upstream_milestone_libe...
: FutureFeature, OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 09:30 EDT by Eoghan Glynn
Modified: 2016-04-07 17:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:07:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2015-09-08 09:30:45 EDT
Add Total RAM Buffered ("1.3.6.1.4.1.2021.4.14.0") and Total Cached Memory ("1.3.6.1.4.1.2021.4.15.0") to the set of SNMP metrics that are polled for.
Comment 3 Chris Dent 2015-09-11 05:50:56 EDT
Testing this requires a machine running snmpd. It can be the same machine on which you are doing testing or can be an instance you create[1]. Quite some time ago I wrote up this: https://tank.peermore.com/tanks/cdent-rhat/SnmpWithCeilometer

which provides some nitty gritty on how to get things set up.

If you're using an install that is already configured to do snmp metering, some of these steps can be skipped and you can just do the "did I get some meters" section at the end.

Once you have confirmed (with an snmpwalk) that snmp is even functioning you can test that it is being polled by:

* If you are not using an instance, configuring a manual resource in pipeline.yaml:

     - name: meter_snmp
       interval: 30
       resources:
           - snmp://hizzouse@192.168.2.2
       meters:
           - "hardware.cpu*"
           - "hardware.memory*"
           - "hardware.disk*"
           - "hardware.network*"
      sinks:
        - meter_sink

"hizzouse" should be replaced by the snmp community, 192.168.2.2 with the IP of the machine on which you have configured sndmpd (see the link above for more details).

* Restart the polling agent that is polling the central namepsace.
* Wait the polling interval and then check for samples:

In the polling agent log you will see entries like:

Polling pollster hardware.memory.buffer in the context of meter_snmp
Polling pollster hardware.memory.cached in the context of meter_snmp

If you do a search for samples for the IP of the snmpd running host:

$ ceilometer sample-list -q resource_id=192.168.2.2

you will see a variety of hardware metrics, including 'hardware.memory.buffer' and 'hardware.memory.cached'.

If you are testing using an instance and the instance was discoverd, then you'll need to query by resource_id.

[1] I find using an instance less easy as you have to configure it for snmp and snmp access and if you're going to do that may as well just do it on the machine you're currently working on.
Comment 5 Yurii Prokulevych 2016-02-15 06:50:59 EST
Verified according test plan.
Packages: openstack-ceilometer*-5.0.2-1.el7ost.noarch
Comment 7 errata-xmlrpc 2016-04-07 17:07:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.