Bug 1261056 - Place bonding-defaults.json outside of /var/lib/vdsm
Place bonding-defaults.json outside of /var/lib/vdsm
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.0.0-alpha
: 4.17.999
Assigned To: Ondřej Svoboda
Meni Yakove
:
Depends On:
Blocks: 1260746
  Show dependency treegraph
 
Reported: 2015-09-08 09:47 EDT by Fabian Deutsch
Modified: 2016-07-05 03:52 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:52:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54850 master MERGED bonding: move pre-generated data to /usr/share/vdsm 2016-03-29 07:10 EDT

  None (edit)
Description Fabian Deutsch 2015-09-08 09:47:37 EDT
Description of problem:
bonding-defaults.json (https://gerrit.ovirt.org/gitweb?p=vdsm.git;a=blob;f=vdsm/bonding-defaults.json;hb=HEAD) provides some defaults for bonds.
As these are vendor/vdsm provided defaults it should not live inside /var/lib, rather in /usr/lib where a vendor can put his defaults.

/etc/vdsm/bonding-defaults.json could then be a place, which a user can use to override the defaults provided by vdsm.
Comment 1 Dan Kenigsberg 2015-11-29 05:33:55 EST
Some background: this bug was opened when testing Vdsm in a container, where /var/lib is created afresh on startup.

/var/lib/vdsm/bonding-defaults.json is shipped with Vdsm only because creating it on Vdsm startup has conflicted with a currently-running NetworkManager (see commit message of http://gerrit.ovirt.org/33403).

Until NetworkManager is convinced not to touche our reference bond, we'd better move the json file to /usr/lib/vdsm.
Comment 3 Mike McCune 2016-03-28 19:15:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Michael Burman 2016-04-10 04:33:30 EDT
Hi 

How this bug should be tested? Thanks
Comment 5 Dan Kenigsberg 2016-04-10 06:07:27 EDT
verify that `rpm -ql vdsm |grep /var/lib/vdsm` is empty, yet `vdsm-tool dump-bonding` works, as well as Vdsm as a whole.
Comment 6 Michael Burman 2016-04-11 10:43:39 EDT
Verified on - vdsm-4.17.999-909.git28d724a.el7.centos.noarch
Comment 7 Sandro Bonazzola 2016-07-05 03:52:34 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.