Bug 126106 - usb mouse with Wacom tablet freezes after kernel upgrade
usb mouse with Wacom tablet freezes after kernel upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 23:32 EDT by Ferindo Middleton Jr
Modified: 2015-01-04 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 00:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel2.6.6-1.435.2.3 (dmesg) log file (9.84 KB, text/plain)
2004-07-04 10:45 EDT, Ferindo Middleton
no flags Details

  None (edit)
Description Ferindo Middleton Jr 2004-06-15 23:32:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I currently run kernel-2.6.5-1.358. After upgrading to kernel-2.6.6-
1.427 the mouse pointer freezes to the upper right hand of screen and 
doesn't repond to mouse movement very much at all. I even tried 
upgrading to kernel-2.6.6-1.435 using yum fedora channel and the same 
malfunction happens. Pretty sure it's the kernel upgrade that causes 
the mouse malfunction (no other related peripheral updates applied to 
system...) rebooting the kernel back down to kernel-2.6.5-1.358 
enables mouse to function normally again. This problem would problem 
affect other usb devices for others.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.427

How reproducible:
Always

Steps to Reproduce:
1. Connect usb Wacom tablet to intel architecture running FC2, kernel 
kernel-2.6.5-1.358 (Watch usb mouse work just fine)
2. Upgrade to kernel kernel-2.6.6-1.427 or kernel-2.6.6-1.435
3. Watch pointer jump to up right-hand corner of screen and usb mouse 
not work just fine anymore
4. Reboot system using kernel-2.6.5-1.358 again and watch it work 
like normal again.
    

Actual Results:  Usb Wacom tablet nmouse won't work after upgrading 
to kernel-2.6.6-1.427.

Expected Results:  Expected mouse functioning to continue flawlessly 
to work without any need for reconfiguration just because of kernel 
upgrade.

Additional info:
Comment 1 Ferindo Middleton 2004-06-30 22:18:17 EDT
I've used the Yum fedora channel to install and run kernel 2.6.6-
1.435.2.1 - The same issue with the kernel not properly handling the 
usb Wacom tablet mouse as described in steps 1-4 for reproducing 
this "bug" still exists.... rebooting the machine and loading the the 
older kernel-2.6.5-1.358 kernel (Step 4) enables the machine to 
properly recognize and operate the mouse again.
Comment 2 Ferindo Middleton 2004-07-04 10:45:44 EDT
Created attachment 101619 [details]
kernel2.6.6-1.435.2.3 (dmesg) log file

Upgraded to kernel2.6.6-1.435.2.3 through Fedora yum channel. Wacom tablet
still doesn't work. Don't know id this is REALLY kernel backwards compatibility
problem with USB device or Driver/configuration problem. Made no configuration
changes; downgrading to older version of kernel allows USB Wacom tablet/mouse
to work again...
Comment 3 Ferindo Middleton 2004-07-05 22:57:48 EDT
 --------------------- Kernel Begin ------------------------
                                                                     
          
                                                                     
          
WARNING:  Kernel Errors Present
   end_request: I/O error, dev hdc, sector...:  4 Time(s)
   hdc: command error: error=0x54...:  4 Time(s)
   hdc: command error: status=0x51 { D...:  4 Time(s)
   hid: probe of 2-2:1.0 failed with error -5...:  1 Time(s)
   usbhid: probe of 2-2:1.0 failed with error -5...:  1 Time(s)
   vesafb: probe of vesafb0 failed with error -6...:  1 Time(s)
                                                                     
          
 ---------------------- Kernel End -------------------------
Comment 4 Felix Schwarz 2004-09-04 08:59:30 EDT
I think this is a kernel related problem:
http://sourceforge.net/mailarchive/forum.php?thread_id=5155500&forum_id=5398
http://nopaste.php.cd/23795

This patch isn't included in the vanilla kernel (afaik).
Comment 5 Felix Schwarz 2004-09-04 09:07:23 EDT
I just noticed
http://sourceforge.net/mailarchive/message.php?msg_id=9097380

Hopefully they'll include that into 2.6.9 so that bug will go away.
Comment 6 Stefan Seefeld 2004-11-19 12:52:33 EST
I'm having major problems with my usb wacom tablet, too.
It used to work with 2.4.x kernels on FC1.
I believe the error showed up as soon as I upgraded to 
a 2.6.x kernel.
I'v now even had problems installing FC3 because of some
conflicts. When I unplug the wacom installation goes
smoothly.

Plugging the wacom back into the running machine results
into the following messages in /var/log/messages:

Nov 17 22:22:42 marvin kernel: hub 2-2:1.0: hub_port_status failed
(err = -71)
Nov 17 22:22:42 marvin kernel: hub 2-2:1.0: cannot reset port 2 (err =
-71)
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: hub_port_status failed
(err = -71)
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: cannot reset port 2 (err =
-71)
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: cannot reset port 2 (err =
-71)
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: Cannot enable port 2. 
Maybe the USB cable is bad?
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: cannot disable port 2 (err
= -71)
Nov 17 22:22:43 marvin kernel: hub 2-2:1.0: cannot reset port 2 (err =
-71)
Nov 17 22:22:43 marvin last message repeated 4 times

...

Is there anything else I can do to help resolve this problem ?
Comment 7 Ferindo Middleton Jr 2004-11-20 00:16:22 EST
I've upgraded to Fedora Core 3 and running with kernel 2.6.9-1.667. If
this problem was with the kernel, it has been fixed now etheir by
updates to accomodate this usb tablets functiaonality or in a
misconfiguration somewhere that has been corrected with FC's awareness
of external usb devices. At any rate, I'm satisfied with the mouse's
functionality since upgrading to FC3. 
Comment 8 Ferindo Middleton Jr 2004-11-20 00:24:31 EST
I'm the originator of this bug... And I say the problem has been
totally fixed with improvements to the kernel and default
configurations that come with FC3. I think this bug needs to be closed
now, and I think that it was at least updates that came with kernel
2.6.9-1.667 that resolved the 'bug'. Let's close this.

Note You need to log in before you can comment on or make changes to this bug.