Bug 1261070 - Reproducible LVM errors on a few systems when .cache file contains a device that is no longer on the system
Reproducible LVM errors on a few systems when .cache file contains a device t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.6
All Linux
high Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
cluster-qe@redhat.com
: ZStream
Depends On: 1260194
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 10:07 EDT by Jan Kurik
Modified: 2015-09-21 08:48 EDT (History)
12 users (show)

See Also:
Fixed In Version: lvm2-2.02.111-2.el6_6.6
Doc Type: Bug Fix
Doc Text:
When the /etc/lvm/cache/.cache file contained an entry that did not exist, the code processed an uninitialized structure which led to unreliable behavior. As a consequence, an error message referencing an undefined (major, minor) pair was returned. With this update, non-existent devices are handled correctly while processing the .cache file, and the aforementioned error message is no longer generated.
Story Points: ---
Clone Of: 1260194
Environment:
Last Closed: 2015-09-21 08:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1813 normal SHIPPED_LIVE lvm2 bug fix update 2015-09-21 12:47:41 EDT

  None (edit)
Description Jan Kurik 2015-09-08 10:07:10 EDT
This bug has been copied from bug #1260194 and has been proposed
to be backported to 6.6 z-stream (EUS).
Comment 6 errata-xmlrpc 2015-09-21 08:48:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1813.html

Note You need to log in before you can comment on or make changes to this bug.