Bug 1261071 - Reproducible LVM errors on a few systems when .cache file contains a device that is no longer on the system
Summary: Reproducible LVM errors on a few systems when .cache file contains a device t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1260194
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-08 14:07 UTC by Jan Kurik
Modified: 2019-09-12 08:53 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.118-3.el6_7.3
Doc Type: Bug Fix
Doc Text:
When the /etc/lvm/cache/.cache file contained an entry that no longer existed, the code read an uninitialised structure which lead to unreliable behaviour. This bug exposed itself as messages with undefined major and minor numbers. For example: /dev/nonexistent_device: stat failed: No such file or directory Path /dev/nonexistent_device no longer valid for device(0,1) This has been fixed and nonexistent devices are handled correctly while reading the .cache file. The messages referencing undefined (major,minor) pair are not generated and unitialized structures are not used anymore.
Clone Of: 1260194
Environment:
Last Closed: 2015-09-22 14:03:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1823 normal SHIPPED_LIVE lvm2 bug fix update 2015-09-22 17:47:20 UTC

Description Jan Kurik 2015-09-08 14:07:34 UTC
This bug has been copied from bug #1260194 and has been proposed
to be backported to 6.7 z-stream (EUS).

Comment 6 errata-xmlrpc 2015-09-22 14:03:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1823.html


Note You need to log in before you can comment on or make changes to this bug.