Bug 1261090 - [RFE][nova]: Fix resource tracking for operations that move instances between hosts
[RFE][nova]: Fix resource tracking for operations that move instances between...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Prasanth Anbalagan
https://blueprints.launchpad.net/nova...
upstream_milestone_liberty-rc1 upstre...
: FutureFeature
Depends On:
Blocks: 1281573 1396164
  Show dependency treegraph
 
Reported: 2015-09-08 10:39 EDT by Stephen Gordon
Modified: 2016-11-17 14:20 EST (History)
13 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 193576 None None None Never
OpenStack gerrit 197137 None None None Never
OpenStack gerrit 197138 None None None Never
OpenStack gerrit 197525 None None None Never
OpenStack gerrit 197526 None None None Never
OpenStack gerrit 197668 None None None Never
OpenStack gerrit 197669 None None None Never
OpenStack gerrit 199678 None None None Never
OpenStack gerrit 199679 None None None Never
OpenStack gerrit 200485 None None None Never
OpenStack gerrit 213461 None None None Never
OpenStack gerrit 214713 None None None Never
OpenStack gerrit 214770 None None None Never
OpenStack gerrit 216731 None None None Never
OpenStack gerrit 216732 None None None Never
OpenStack gerrit 216733 None None None Never
OpenStack gerrit 218201 None None None Never
OpenStack gerrit 218385 None None None Never
OpenStack gerrit 218500 None None None Never
OpenStack gerrit 218938 None None None Never

  None (edit)
Description Stephen Gordon 2015-09-08 10:39:14 EDT
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/migration-fix-resource-tracking.

Description:

Resource tracking for operations that move instances between compute hosts is
broken in Nova. The fix requires some refactoring and tweaking of the data
model so it's discussed in a spec. It's really about fixing of several long
standing bugs.

Specification URL (additional information):

http://specs.openstack.org/openstack/nova-specs/specs/liberty/approved/migration-fix-resource-tracking.html
Comment 3 Stephen Gordon 2015-09-08 10:43:27 EDT
Per blueprint, last patch merged for Liberty was https://review.openstack.org/#/c/216733 - need to work out what if anything we can verify (probably mostly regression testing?) for Liberty/8.0 and split remaining patches out for Mitaka.
Comment 7 errata-xmlrpc 2016-04-07 17:07:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.