Bug 1261096 - [RFE][nova]: New nova API call to mark nova-compute down.
[RFE][nova]: New nova API call to mark nova-compute down.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: beta
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Gabriel Szasz
https://blueprints.launchpad.net/nova...
upstream_milestone_liberty-3 upstream...
: FutureFeature
Depends On:
Blocks: 1178665
  Show dependency treegraph
 
Reported: 2015-09-08 10:48 EDT by Stephen Gordon
Modified: 2016-04-07 17:07 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:07:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 169836 None None None Never
OpenStack gerrit 184086 None None None Never
OpenStack gerrit 185279 None None None Never
OpenStack gerrit 185280 None None None Never
OpenStack gerrit 197063 None None None Never
OpenStack gerrit 209766 None None None Never

  None (edit)
Description Stephen Gordon 2015-09-08 10:48:34 EDT
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/mark-host-down.

Description:

New API call is needed to change the state of compute service "down"
immediately. This allows usage of evacuate API without a delay. Also as
external system will make sure host is down and no VMs left running, there
will be no possibility to break shared storage or use same IPs again.

Specification URL (additional information):

http://specs.openstack.org/openstack/nova-specs/specs/liberty/approved/mark-host-down.html
Comment 3 Stephen Gordon 2015-09-09 10:51:01 EDT
Hi Fabio,

How would you like to track the need to also update the agent(s) to take advantage of this API if it's available?

Thanks,

Steve
Comment 4 Fabio Massimo Di Nitto 2015-09-09 11:28:12 EDT
(In reply to Stephen Gordon from comment #3)
> Hi Fabio,
> 
> How would you like to track the need to also update the agent(s) to take
> advantage of this API if it's available?
> 
> Thanks,
> 
> Steve

As soon as the API is available in RDO we can clone the bz for fence-agents but we need to keep in mind that fence-agents is in RHEL Base OS and follows a different schedule. so we need to be a bit smart in landing the code to avoid sync issues.
Comment 9 errata-xmlrpc 2016-04-07 17:07:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.