Bug 1261107 - no talloc stackframe at ../source3/libsmb/clifsinfo.c:497, leaking memory
no talloc stackframe at ../source3/libsmb/clifsinfo.c:497, leaking memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On: 1261080
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 11:15 EDT by Remi Collet
Modified: 2016-11-04 02:58 EDT (History)
12 users (show)

See Also:
Fixed In Version: samba-4.4.4-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261080
Environment:
Last Closed: 2016-11-04 02:58:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 11177 None None None Never

  None (edit)
Description Remi Collet 2015-09-08 11:15:00 EDT
+++ This bug was initially created as a clone of Bug #1261080 +++

With libsmbclient-4.1.17-1.fc21

Description of problem:
I work in a libsmbclient wrapper for PHP
https://github.com/eduardok/libsmbclient-php

Running the test suite I got this message.
no talloc stackframe at ../source3/libsmb/clifsinfo.c:497, leaking memory

This is raised when calling smbc_statvfs or smbc_fstatvfs.

Diggin in the libsmb source, in source3/libsmb/clifsinfo.c a call to talloc_tos is done, but no call to talloc_stackframe.

Diffing various version, I think this is fixed in 4.2 / 4.3

--- Additional comment from Remi Collet on 2015-09-08 10:27:04 EDT ---

I think RHEL-7 version is also affected.

--- Additional comment from Remi Collet on 2015-09-08 10:52:30 EDT ---

I confirm a rebuild of the F21 .src.rpm with the attached patch fix this issue.
Comment 2 Remi Collet 2015-09-08 11:16:01 EDT
Cloned for RHEL-7 as libsmbclient-4.1.12-23.el7_1 also affected.
Comment 4 Robin Hack 2016-02-22 06:43:38 EST
QA_ACK+ for rhel7.3. SanityOnly.
Comment 6 Robin Hack 2016-07-27 04:16:31 EDT
Sanity Only!
Comment 8 errata-xmlrpc 2016-11-04 02:58:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2468.html

Note You need to log in before you can comment on or make changes to this bug.