Bug 1261124 - libnfsidmap: strip newlines out of IDMAP_LOG messages
libnfsidmap: strip newlines out of IDMAP_LOG messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libnfsidmap (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On:
Blocks: 1422417
  Show dependency treegraph
 
Reported: 2015-09-08 11:57 EDT by Steve Dickson
Modified: 2017-02-15 04:58 EST (History)
3 users (show)

See Also:
Fixed In Version: libnfsidmap-0.25-13.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1422417 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:08:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2272 normal SHIPPED_LIVE libnfsidmap bug fix update 2016-11-03 09:34:46 EDT

  None (edit)
Description Steve Dickson 2015-09-08 11:57:54 EDT
Description of problem:

When logging to syslog, they aren't needed (or desirable) and when
logging to stderr the logging function generally adds it itself.

Note that I did not change gums.c since it defaults to using printf()
as a logging function.
Comment 3 Steve Dickson 2016-04-07 10:40:09 EDT
Upstream commmit 

commit 6fc893187db3fceb66129a3fd8437f663a5e33d0
Author: Jeff Layton <jeff.layton@primarydata.com>
Date:   Tue Sep 8 11:59:25 2015 -0400

    Strip newlines out of IDMAP_LOG messages
Comment 6 Yongcheng Yang 2016-05-27 00:25:38 EDT
Move to VERIFIED as comment 5 and continue to run the automatic case.
Comment 8 errata-xmlrpc 2016-11-03 22:08:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2272.html

Note You need to log in before you can comment on or make changes to this bug.