Bug 1261145 - jabberd daemons hit into SELinux when reading SSL certificates
jabberd daemons hit into SELinux when reading SSL certificates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.8
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 13:11 EDT by Matěj Cepl
Modified: 2016-05-10 16:01 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-288.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:01:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0763 normal SHIPPED_LIVE selinux-policy bug fix update 2016-05-10 18:33:46 EDT

  None (edit)
Description Matěj Cepl 2015-09-08 13:11:07 EDT
Description of problem:
[root@redcrew owncloud]# ausearch -m AVC -ts 18:00|grep luther|audit2why
    type=AVC msg=audit(1441728308.635:3577): avc:  denied  { getattr } for  pid=1513 comm="s2s" path="/etc/pki/tls/certs/luther.ceplovi.cz-intermediate.crt" dev=vda2 ino=7103 scontext=system_u:system_r:jabberd_t:s0 tcontext=unconfined_u:object_r:cert_t:s0 tclass=file
     
            Was caused by:
                    Missing type enforcement (TE) allow rule.
     
                    You can use audit2allow to generate a loadable module to allow this access.
     
    type=AVC msg=audit(1441728308.633:3576): avc:  denied  { open } for  pid=1513 comm="s2s" name="luther.ceplovi.cz-intermediate.crt" dev=vda2 ino=7103 scontext=system_u:system_r:jabberd_t:s0 tcontext=unconfined_u:object_r:cert_t:s0 tclass=file
     
            Was caused by:
                    Missing type enforcement (TE) allow rule.
     
                    You can use audit2allow to generate a loadable module to allow this access.
     
    type=AVC msg=audit(1441728308.633:3576): avc:  denied  { read } for  pid=1513 comm="s2s" name="luther.ceplovi.cz-intermediate.crt" dev=vda2 ino=7103 scontext=system_u:system_r:jabberd_t:s0 tcontext=unconfined_u:object_r:cert_t:s0 tclass=file
     
            Was caused by:
                    Missing type enforcement (TE) allow rule.
     
                    You can use audit2allow to generate a loadable module to allow this access.
     
    [root@redcrew owncloud]#

It seems that this module makes things work:

[root@redcrew ~]# cat jabberdSSLCert.te 

module jabberdSSLCert 1.0;

require {
	type cert_t;
	type jabberd_t;
	class file { read getattr open };
}

#============= jabberd_t ==============
allow jabberd_t cert_t:file { read getattr open };
[root@redcrew ~]#

Version-Release number of selected component (if applicable):
jabberd-2.2.14-6.el6.x86_64
Comment 1 Matěj Cepl 2015-09-08 13:12:27 EDT
jabberd is in EPEL
Comment 15 errata-xmlrpc 2016-05-10 16:01:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0763.html

Note You need to log in before you can comment on or make changes to this bug.