Bug 1261146 - Legacy files pre-existing tier attach must be promoted
Legacy files pre-existing tier attach must be promoted
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: Triaged
: 1262885 (view as bug list)
Depends On: 1252586 1271705
Blocks: 1260923 glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-09-08 13:16 EDT by Joseph Elwin Fernandes
Modified: 2016-06-19 20:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1252586
Environment:
Last Closed: 2015-11-17 00:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Elwin Fernandes 2015-09-08 13:16:10 EDT
+++ This bug was initially created as a clone of Bug #1252586 +++

Files that exist before a tier is attached are called "legacy files". They should be promoted to the hot tier when accessed. In some cases they are not if the parent gfid (directory the file belongs in) is unavailable.

--- Additional comment from Anand Avati on 2015-08-11 15:54:09 EDT ---

REVIEW: http://review.gluster.org/11828 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-18 07:24:02 EDT ---

REVIEW: http://review.gluster.org/11828 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-21 06:55:50 EDT ---

REVIEW: http://review.gluster.org/11828 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-21 11:51:10 EDT ---

REVIEW: http://review.gluster.org/11828 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#5) for review on master by Joseph Fernandes

--- Additional comment from Anand Avati on 2015-08-27 13:14:14 EDT ---

REVIEW: http://review.gluster.org/11828 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 1 Vijay Bellur 2015-09-08 13:18:06 EDT
REVIEW: http://review.gluster.org/12131 (tier/ctr: Lookup heal of cold tier during attach tier) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-10-10 13:51:09 EDT
REVIEW: http://review.gluster.org/12331 (tier/ctr: CTR DB named lookup heal of cold tier during attach tier) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 3 Vijay Bellur 2015-10-10 21:10:22 EDT
COMMIT: http://review.gluster.org/12331 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 2def6bbfc72f9dd7ae6a16befdaf45ac1076b648
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Aug 4 20:38:06 2015 +0530

    tier/ctr: CTR DB named lookup heal of cold tier during attach tier
    
    Heal hardlink in the db for already existing data in the cold
    tier during attach tier. i.e during fix layout do lookup to files
    in the cold tier.
    
    CTR xlator on the  brick/server side does db update/insert of the hardlink on a namelookup.
    Currently the namedlookup is done synchronous to the fixlayout that is
    triggered by attach tier. This is not performant, adding more time to
    fixlayout. The performant approach is record the hardlinks on a compressed
    datastore and then do the namelookup asynchronously later, giving the ctr db
    eventual consistency
    
    master patch : http://review.gluster.org/#/c/11828/
    
    >>Change-Id: I4ffc337fffe7d447804786851a9183a51b5044a9
    >>BUG: 1252586
    >>Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    >>Reviewed-on: http://review.gluster.org/11828
    >>Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >>Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >>Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I61b185a54ae4e8c1d82804b95a278bfbea870987
    BUG: 1261146
    Reviewed-on: http://review.gluster.org/12331
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Raghavendra Talur 2015-11-17 00:57:59 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 5 Joseph Elwin Fernandes 2016-02-14 02:05:27 EST
*** Bug 1262885 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.