Bug 126115 - FC2 Fails to bring up eth0 (natsemi)
FC2 Fails to bring up eth0 (natsemi)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 04:40 EDT by Robert Thomas
Modified: 2013-07-02 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 13:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Thomas 2004-06-16 04:40:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I dont know if this is kudzu related or not, but this was the closest
category I could think of.

FC2 fails to bring up eth0 and obtain an IP address.  I can manually
start eth0 and transmit packets, but cannot receive any.  It appears
to be interrupt related (hunch).

I can install the kernel from FC1, boot with that kernel and eth0
comes up and works.  I can then boot with the FC2 kernel and eth0 works!

I tried all combo's of acpi=off pci=noacpi apm=off.
I also tried the chmod -x /sbin/mii-tool

Hardware

Dual Pentium III 1.13GHz/133
1 GigaByte DDR
NVidia GeForce 5700 FX
Sound Blaster Live!
Hauppage WinTV
DVD ROM
Two IDE Hard Drives
NetGear FA-XXX (natsemi driver)
00:0a.0 Ethernet controller: National Semiconductor Corporation
DP83815 (MacPhyter) Ethernet Controller
        Subsystem: Netgear: Unknown device f312
        Flags: bus master, medium devsel, latency 32, IRQ 129
        I/O ports at d000
        Memory at e3000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 2
2. Reboot 
3. eth0 will not come up (natsemi)
    

Actual Results:  eth0 is deferred

Expected Results:  eth0 to come up and obtain an IP address.

Additional info:
Comment 1 Robert Thomas 2004-06-16 04:42:22 EDT
Forgot, Via Apollo Pro266T North Bridge.
Comment 2 Alan Cox 2004-06-18 22:56:04 EDT
Is there anything interesting in "dmesg" or /var/log/messages about
the ethernet ?
Comment 3 Robert Thomas 2004-06-19 01:56:48 EDT
I have tested SUSE also, it will not bring up the nic either.  I have 
installed the 2.6.6 kernel from kernel.org and it will not bring the 
nic up either.  It seems that once I boot with 2.4.2X kernel, any 2.6 
can boot thereafter. 
 
Nothing in dmesg.  Just the deferred message during init. 
 
My guess is that it has to do with IRQ routing (BIOS & registers), 
the kernel and kudzu.  My BIOS is old (2001). 
 
Byte 
Comment 4 Robert Thomas 2004-06-30 00:53:16 EDT
My workaround is to install FC2 and reboot. 
Install FC1 2.4 kernel from CD and reboot. 
Let kudzu find new network device, make sure nic works. 
Reboot with 2.6 kernel, and everything is happy. 
 
Byte 
Comment 6 Neil Horman 2004-10-18 16:38:30 EDT
I can try doing a clean FC2 install here, but I've tried deleting my
kudzu config several times now, and rebooting under varying kernels
from pre FC2 releases, to the latest out of bitkeeper, and they all
seem to run the card properly, I have no problems send or receiving
traffic.

When you see this problem occur, can you cat /proc/interrupts and see
if the requisite interrupt counter increments while you try to send or
receive traffic?  If it doesn't then your most likely correct, in that
this is a BIOS issue.
Comment 7 Robert Thomas 2004-10-31 09:23:33 EST
I do not have this hardware anymore and cannot test.  Sorry.

Byte

Note You need to log in before you can comment on or make changes to this bug.