Bug 1261151 - [docker-storage-setup] docker-storate-setup warn/error when if growpart is not installed
[docker-storage-setup] docker-storate-setup warn/error when if growpart is no...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Vivek Goyal
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 13:37 EDT by Chris Evich
Modified: 2016-01-07 15:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 15:49:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Evich 2015-09-08 13:37:02 EDT
Description of problem:
This is related to Bug 1226990 and Bug 1241256.

If GROWPART=true d-s-s option is specified but growpart is not installed or fails, then d-s-s should report the error and exit non-zero w/o continuing.  It is incorrect behaviour (IMHO) to continue attempting to configure storage since an explicit option was specified and should be assumed as desired.

Version-Release number of selected component (if applicable):
docker-1.7.1-108

How reproducible:
reliably since docker-1.6.x

Steps to Reproduce:
1. Make sure cloud-utils-growpart is NOT installed (or /usr/bin/growpart is missing or will fail)
2. Add GROWPART=true option to /etc/sysconfig/docker-storage-setup
4. Start docker.service

Actual results:
On docker.service start, d-s-s runs the first time automatically.  It does not extend any partitions, does not report any errors in logs, and continues to create thinpool LV.  Docker service starts successfully, using an undesired storage configuration.

Expected results:
On docker.service start, d-s-s prints & logs an error that GROWPART=true was specified but /bin/growpart binary could not be found or failed.  No further operations are performed and non-zero exit status is returned resulting in docker.service startup failure.

Additional info:
Problem is reproducible on RHEL and Atomic (if first remove/move growpart binary or cause it to fail).  Also, it would be good to document optional /usr/bin/growpart dependency for the GROWPART option.
Comment 2 Vivek Goyal 2015-09-11 12:19:15 EDT
Patch got merged upstream


https://github.com/projectatomic/docker-storage-setup/pull/79
Comment 3 Daniel Walsh 2015-09-29 09:56:35 EDT
Fixed in docker-1.9

Note You need to log in before you can comment on or make changes to this bug.