Bug 126118 - Grubby updates more entries than wanted
Grubby updates more entries than wanted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 05:43 EDT by Karl-Olov Serrander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 13:55:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of wrong behaviour (1.50 KB, text/plain)
2004-08-05 02:38 EDT, Karl-Olov Serrander
no flags Details

  None (edit)
Description Karl-Olov Serrander 2004-06-16 05:43:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When i do:
grubby --add-kernel=/boot/vmlinuz.fc1 --initrd=/boot/initrd.fc1
--title="Reinst TEST" --args="ks:nfs:serverpath"

the --args="ks:nfs:serverpath" is applied to lines other than the
kernel i specified.

This does not work in FC2 either, but worked in RH9.

Version-Release number of selected component (if applicable):
mkinitrd-3.5.14-1

How reproducible:
Always

Steps to Reproduce:
1. grubby --add-kernel=/boot/vmlinuz.fc1 --initrd=/boot/initrd.fc1
--title="Reinst TEST" --args="ks:nfs:serverpath"
2.
3.
    

Actual Results:  I get the following in my /boot/grub/grub.conf:
default=1
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Reinst TEST
        kernel /vmlinuz-fc1 ks:nfs:serverpath
        initrd /initrd-fc1
title Fedora Core (2.6.6-1.435)
        root (hd0,0)
        kernel /vmlinuz-2.6.6-1.435 ro root=LABEL=/ quiet
ks:nfs:serverpath
        initrd /initrd-2.6.6-1.435.img
title Fedora Core (2.6.6-1.427)
        root (hd0,0)
        kernel /vmlinuz-2.6.6-1.427 ro root=LABEL=/ quiet
ks:nfs:serverpath
        initrd /initrd-2.6.6-1.427.img
title Fedora Core (2.6.5-1.358)
        root (hd0,0)
        kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ quiet
        initrd /initrd-2.6.5-1.358.img

Expected Results:  Only title "kernel /vmlinuz-fc1" should have
"ks:nfs:serverpath"

Additional info:
Comment 1 Jeremy Katz 2004-08-04 15:13:49 EDT
This seems to work for me here with current grubby (mkinitrd-4.0.1,
although it hasn't changed since fc2).

Can you verify that it's definitely broken with the mkinitrd shipped
in FC2?  If so, include both your original grub.conf, the one you get
after it modifies it and the command line you used.
Comment 2 Karl-Olov Serrander 2004-08-05 02:38:09 EDT
Created attachment 102440 [details]
example of wrong behaviour
Comment 3 Karl-Olov Serrander 2004-08-05 02:40:20 EDT
For me it is broken in FC2 too, ok in FC3t1. see attached file
grub_sample.txt.
Comment 4 Jeremy Katz 2004-08-10 13:55:26 EDT
Rebuilding the FC2 package with the current devel compiler makes the
problem go away so it looks like it's probably some subtle compiler
bug getting tickled.  Since it's fixed with gcc 3.4, closing accordingly

Note You need to log in before you can comment on or make changes to this bug.