Bug 1261182 - enable doesn't work once disabled via HTTPS Everywhere menu
enable doesn't work once disabled via HTTPS Everywhere menu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla-https-everywhere (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 15:42 EDT by Russell Golden
Modified: 2016-11-21 10:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-21 10:53:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Golden 2015-09-08 15:42:29 EDT
HTTPS Everywhere, if disabled via the button menu, will not re-enable through the button menu.

The cure seems to be to open about:config, and change the preference manually.

This bug does not seem to exist on Windows.

Tested on Fedora 22 with SeaMonkey, without and with a fresh profile.
Comment 1 Andre Robatino 2015-09-08 16:11:21 EDT
As requested in https://bodhi.fedoraproject.org/updates/FEDORA-2015-15186 , I checked using mozilla-https-everywhere-5.1.1-1.fc22.noarch and firefox-40.0.3-1.fc22.x86_64, and the bug still exists with a fresh Firefox profile. BTW, I'm guessing the about:config preference you're talking about is extensions.https_everywhere.globalEnabled, since enabling it manually works after restarting the browser (but not immediately, as the button menu normally would).
Comment 2 Russell Golden 2015-09-08 16:25:40 EDT
Yes, that's the one. The pop-up menu said it was enabled after toggling that preference, but the icon did not change back to its normal color. I suppose I should've tested more thoroughly.

I can't imagine why this would work fine on Windows, but have issues on other platforms. HTTPS Everywhere contains no executable binaries or libraries, only javascript, XUL, and rules in SQLite format.

I'll forward this upstream.
Comment 3 Andre Robatino 2015-09-09 06:21:06 EDT
I think you want the Status to be ASSIGNED rather than VERIFIED (which would indicate you already had a bug fix)?
Comment 4 Russell Golden 2015-09-11 12:02:14 EDT
My mistake. I assumed "verified" meant "able to reproduce; verified as a bug." Status changed.
Comment 5 Dominik 'Rathann' Mierzejewski 2016-11-21 07:58:22 EST
Works for me in Firefox 50 on Fedora 25. Please test the F23 build: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f3ae23d36
Comment 6 Andre Robatino 2016-11-21 09:58:53 EST
Works for me with mozilla-https-everywhere-5.1.4-1.fc25.noarch and firefox-49.0.2-1.fc25.x86_64 on Fedora 25 (I seem to remember having noticed this being fixed a while ago, but forgot to report back). Also works with mozilla-https-everywhere-5.1.9-1.fc24.noarch and firefox-50.0-1.fc24.i686 on Fedora 24. Unfortunately, I don't have a F23 machine anymore to test on, sorry.
Comment 7 Dominik 'Rathann' Mierzejewski 2016-11-21 10:53:30 EST
Thanks for testing. I'll close this for now. If it's still happening on F23, anyone is free to reopen.

Note You need to log in before you can comment on or make changes to this bug.