Bug 1261187 - [AMQP 1.0] Fix heartbeat anomalies (backport into MRG 3.2)
[AMQP 1.0] Fix heartbeat anomalies (backport into MRG 3.2)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity high
: 3.2
: ---
Assigned To: Gordon Sim
Petr Matousek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 16:16 EDT by Mike Cressman
Modified: 2015-10-13 09:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: qpid-cpp-0.34-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:01:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-6661 None None None Never

  None (edit)
Description Mike Cressman 2015-09-08 16:16:31 EDT
Description of problem:
The first heartbeat is often sent after the full idle period, whereas subsequent heartbeats are sent twice as frequently. This happens on both broker and client. This is a result of the periodic timer task that triggers the heartbeats being out of sync with the times computed by proton.

Also on the client, occasionally a heartbeat is missed. This is in part due to the issue above, but also occasionally due to timing of incoming heartbeats with respect to the timer task, resulting in proton emitting the heartbeat but it not actually being written to the wire.


Version-Release number of selected component (if applicable):
qpid-cpp-0.34

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 7 Petr Matousek 2015-09-29 07:46:39 EDT
This issue has been fixed. All the heartbeats respects the given interval (including the first one). Verified on rhel6.7(i386, x86_64) and rhel7.1(x86_64).

packages:
qpid-cpp-*-0.34-5

-> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.