Bug 1261215 - registergui progress bars pause after registration.
Summary: registergui progress bars pause after registration.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-08 23:39 UTC by Adrian Likins
Modified: 2017-08-01 19:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:18:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1511 None None None 2016-10-24 19:44:18 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Adrian Likins 2015-09-08 23:39:24 UTC
Description of problem:

In subscription-manager-gui-1.16.2-1, after registration the progress bars pause briefly while the main thread persists consumer certs and caches (and after subscribe as well). 

Previously most of that happened in a the subscribe and/or findServiceLevel threads
(along with a whole lot of other things), but the non network parts got moved back into the main thread causing the progress bars to block briefly.

This is split from https://bugzilla.redhat.com/show_bug.cgi?id=1247721, that was also progress bar related, but with a different cause and fixes.


(Also, not really a blocker imo...)

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.16.2-1

How reproducible:

Register to stage, especially with an employee cert

Comment 2 John Sefler 2015-09-25 16:58:50 UTC
deferring to rhel-7.3.0 due to schedule and severity

Comment 4 Shwetha Kallesh 2017-04-05 11:35:07 UTC
Dont see the progress bar pausing while registering or attaching a employee subscription , so marking the bug as verified 

[root@dhcp35-188 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

Comment 5 errata-xmlrpc 2017-08-01 19:18:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.