Bug 1261237 - collectd swap-plugin reports blocks instead of bytes
collectd swap-plugin reports blocks instead of bytes
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: collectd (Show other bugs)
epel7
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 21:41 EDT by tthrockm
Modified: 2015-12-24 00:06 EST (History)
6 users (show)

See Also:
Fixed In Version: collectd-5.5.0-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 00:06:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tthrockm 2015-09-08 21:41:01 EDT
Description of problem: the collectd swap plugin reports values as blocks vs. bytes; the problem was documented in upstream, including fixes, as issue #1062:

https://github.com/collectd/collectd/issues/1062

The fix has been merged into the upstream 5.5 milestone; current 5.5.x packages appear to be (correctly) using the 5.5.0 release target (ffc3836).


Version-Release number of selected component (if applicable): collectd-5.5.0-2.el7

How reproducible: 100%


Steps to Reproduce:
1.install collectd-5.5.0-2.el7
2. enable swap plugin


Actual results:

collected values are reported in blocks

Expected results:

collected values are reported in bytes

Additional info:

See also https://github.com/collectd/collectd/pull/1071 for the patch
Comment 1 Kevin Fenzi 2015-09-14 16:31:50 EDT
So, I take it you would prefer we push an update with this now rather than wait for another upstream release?
Comment 2 Ruben Kerkhof 2015-09-15 08:13:01 EDT
Upstream should have 5.5.1 in a matter of weeks, last I heard.
Comment 3 tthrockm 2015-09-15 15:55:17 EDT
An update would be ideal - we have a workaround (downgrade) in the meantime
Comment 4 Fedora Update System 2015-12-06 16:45:28 EST
collectd-5.5.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f8f995d8a6
Comment 5 Fedora Update System 2015-12-08 02:21:56 EST
collectd-5.5.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update collectd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f8f995d8a6
Comment 6 Fedora Update System 2015-12-24 00:06:19 EST
collectd-5.5.0-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.